Koodo Community
Solved

"RTC Connecting" on Discord

  • 30 October 2021
  • 19 replies
  • 221 views

I recently had to replace the SIM card for my Koodo phone (Xiaomi Mi 8), and now discord voice doesn’t work :(

I noticed the issue right away, and tried changing the SIM again, but I still can’t use discord on data. wi-fi is fine, and everything else works (except my Mi Account  won’t reactivate, which is fine). Anyone else experiencing this? any way to fix it?

icon

Best answer by Allan M 31 October 2021, 20:09

View original

This topic has been closed for comments

19 replies

Userlevel 7
Badge +4

Can you try to log out of the discord app and log in again? Was there any error when you tried to make call? 

thanks for the suggestion! so i’ve tried this twice now, and i’ve also tried:

  • removing and re-inserting the SIM (i cannot move it into slot 2 as slot 2 doesn’t support Koodo)
  • power cycling the phone
  • manually resetting APN settings
  • starting VC on wi-fi, then moving to data (it immediately says “disconnected” followed by RTC connecting)

i want to try a factory reset, but i’m procrastinating on making sure i have my passwords/data backed up :joy:

i don’t get a proper “error” or error code, just “RTC connecting” and “Failed to connect” on loop when trying through data. Skype works, Snap works, LINE works, but not Discord ;w;

 

Userlevel 7
Badge +4

This is a weird error from my Google search. As it worked before on Koodo network, there shouldn’t be any error.

Can you delete the app, restart the phone and reinstall it again? I think there might be some security within discord that created the issue. Hopefully that simple action would resolve it. From my Google search, the issue could be from a VPN or firewall issue with the phone also. Did you have a VPN or a firewall/antivirus app with the phone?

it’s very weird! i can’t find any information on it anywhere! i tried uninstalling, reinstalling, rebooting, all but buying a new phone :joy:

Userlevel 7
Badge +4

Do you happen to have data saver turned on?

data saver? is that in self serve? my phone doesn't seem to have that as a setting

Userlevel 7
Badge +4

data saver? is that in self serve? my phone doesn't seem to have that as a setting

It would be a setting in the app.

Or a setting in your phone's data settings 

discord doesn't have a data saver setting :( could this be like a SIM issue? or some sort of provisioning issue?

 

Userlevel 7
Badge +4

data saver? is that in self serve? my phone doesn't seem to have that as a setting

I’m not sure if this may be the issue causing Discord not to work, but someone else found out it was their service provider that caused it not to work. In the meantime, I have flagged a Koodo rep to look into this. https://www.reddit.com/r/discordapp/comments/fp12yk/discord_not_working_on_mobile_data/

Userlevel 7
Badge +4

Hi @midni 

 

Just to confirm, the voice feature works properly on the other apps, such as Skype, while data is enabled and wi fi off? 

yes! so Skype, Snap, Whatsapp and LINE all work when wifi is off and data is on

Userlevel 7
Badge +4

Just tested it out on my phone on data (with Koodo) and I was able to connect just fine so it wouldn't appear to be as a Koodo wide problem.

(Not that this necessarily helps fix your issue but helps to narrow it down)

thanks for checking, at least! every step helps! some of my discord friends have koodo as well, and i'm the only one of them not working

Userlevel 7
Badge +4

@midni Does this issue affect only a specific dicord server or all that you are trying to use the voice feature for?

As @Allan M suggested, this doesn’t seem to be a Koodo issue or a provisioning issue, but it’s quite a weird coincidence that it started just after sim card replacement.

so /only/ discord voice is affected. app messaging works and my other apps are unaffected, but MMS is also down

Userlevel 7
Badge +4

@midni Do you have issues with MMS feature since you changed the sim card, or it was present also with the old sim card? 

i’ve only had the issue since i changed the SIM! they worked before just fine

Userlevel 7
Badge +4

i’ve only had the issue since i changed the SIM! they worked before just fine

Can you check to make sure your APN settings match what's seen in the link below and also make sure that the koodo apn settings are selected in your phone?

This setting may also appear in your phone as "Access Point Names"

https://www.koodomobile.com/en/help/setting-data-your-non-koodo-phone

i’ve only had the issue since i changed the SIM! they worked before just fine

Can you check to make sure your APN settings match what's seen in the link below and also make sure that the koodo apn settings are selected in your phone?

This setting may also appear in your phone as "Access Point Names"

https://www.koodomobile.com/en/help/setting-data-your-non-koodo-phone

thanks for this!