Koodo Community
Question

How do I turn off roaming on my iPhone?

  • 29 March 2022
  • 9 replies
  • 191 views

iPhone 12 mini, iOS 15.4 … I want to set it for NO Roaming, NONE, Zip, Zilch. To go with Network > Koodo (i.e. not AUTOMATIC)    But on my phone I can’t find the setting. Google searches all give different methods, and none match what I see on my phone - there’s no Roaming setting. Is it only visible when certain other settings are on?


9 replies

Userlevel 7
Badge +4

iPhone 12 mini, iOS 15.4 … I want to set it for NO Roaming, NONE, Zip, Zilch. To go with Network > Koodo (i.e. not AUTOMATIC)    But on my phone I can’t find the setting. Google searches all give different methods, and none match what I see on my phone - there’s no Roaming setting. Is it only visible when certain other settings are on?

If you do not want to use roaming when abroad, make sure you do not have the International Voice Roaming and International Data Roaming add-ons included in your Self-Serve account. That way, it would not automatically connect to a network while travelling in another country. 

I don’t have International on, but in Self-Serve > Mobile Services > Easy Roam it is checked Active for US and I don’t see any way to turn it off.   I’m sure I didn’t ever add it.   It’s probably the nearness of the US border that triggered this. 

Userlevel 7
Badge +4

Are you a prepaid or postpaid customer?

If you are  a postpaid customer, you can’t turn off roaming to US. It is on by default. You can only turn off roaming to other countries by remove the roaming add-on.

If you want to avoid accidental roaming to US, switch the cellular network selection to manual and select Koodo. However, every times, make sure you check it regularly as it could be reverted back to automatic when you reset the phone or change SIM.

 

I pay a monthly bill for a bundle of services, with no extra charges so far. Automatic had turned itsefl on with my last iOS update and I’ve fixed that, so I’ve probably fixed it. I’ll check my next bill when it comes.

Thanks, folks. 

Still wondering how to tell my phone not to roam, though! 

 

 

Userlevel 7
Badge +4

I pay a monthly bill for a bundle of services, with no extra charges so far. Automatic had turned itsefl on with my last iOS update and I’ve fixed that, so I’ve probably fixed it. I’ll check my next bill when it comes.

Thanks, folks. 

Still wondering how to tell my phone not to roam, though! 

To turn off data roaming on your phone, you can follow the instructions by clicking this link for more information. https://support.apple.com/en-us/HT201643

For future reference, a fool-proof way to avoid any roaming charges is to remove your SIM card and shut off your phone when you are travelling around the U.S. border. 

Aha - I had been to that article, but Roaming options are only visible when Cellular Data is on.  Annoyingly, Roaming was already OFF, so it looks as if that Automatic setting that comes with an iOS update is itself enough to allow roaming! 

Removing my SIM card is not an option - I live within sight of the border. But forcing Koodo as the network ought to do it, If only I could lock it that way. 

Badge +4

Aha - I had been to that article, but Roaming options are only visible when Cellular Data is on.  Annoyingly, Roaming was already OFF, so it looks as if that Automatic setting that comes with an iOS update is itself enough to allow roaming! 

Removing my SIM card is not an option - I live within sight of the border. But forcing Koodo as the network ought to do it, If only I could lock it that way. 

To lock your iPhone to the Koodo network, go to Settings > Cellular - tap Network Selection. You should see the name Automatic with a toggle switch beside it. Slide the toggle switch to the off position. From the list, select Koodo as the carrier.

Thanks, Rick, but I did that before, and again yesterday. People are reporting that an iOS update may reset it to Automatic (!!) (??)    and that seems to have happened to me. 

Badge +4

Thanks, Rick, but I did that before, and again yesterday. People are reporting that an iOS update may reset it to Automatic (!!) (??)    and that seems to have happened to me. 

Very odd indeed. Try restarting your iPhone 12 Mini and then apply the manual network selection mode. If it reverts to automatic network selection mode again, only an iOS update will resolve this problem. I’m using an iPhone 12 Pro and have not encountered this bug yet.

Reply