Koodo Community

Data Preferences not updated

I recently added data for the first time to my plan, and am concerned about managing it. On checking my “data preferences” page it still shows me as having “pay per use” data and states my data will not automatically be paused when I reach my limit. 

Shock-Free Data alerts

You've opted not to receive any notifications or to have your data paused when you reach your limit. Additional data will be charged on a pay-per-use basis. If you'd like to change your preferences, please schedule a callback with one of our reps at www.koodo.com/chat

Pay-per-use data roaming alerts

You'll get text alerts for the following pay-per-use (PPU) data roaming charges:





( PPU roaming data will also be paused )

Only users with permissions or access to Self Serve can unpause data and allow additional data to be charged on a pay-per-use basis.


I requested a call-back as it says, spoke to a rep who ASSURED ME that data notifications are on. I waited until the end of the billing cycle and rechecked my account and this page is still wrong.

I see this situation has been reported several times before, so it must be a known glitch.

I have already gone the “request callback” route, what now?




Best answer by Flo Koodo 19 May 2023, 21:18

View original

5 replies

Userlevel 7
Badge +4

Please try to clear your browser’s cache and check again.

Let us know if the issue still remains after doing that

I cleared the cache but it didn’t resolve the problem

Userlevel 7
Badge +4

Let me flag a rep for you to look into this issue

Userlevel 7
Badge +4

Hi @Moonjool 

I have checked and I can confirm that Shock Free data is enabled (notification and pause at 100%), but the notifications at 50% and 90% were not, therefore, I have activated the notifications for data usage on your plan.

You can track the usage in self serve https://www.koodomobile.com/en/help/keeping-track-your-data-usage

Yes I can see it now, thank you!