Koodo Community

unable to change address, so cannot get new phone delivered.

  • 3 November 2023
  • 8 replies

every time I click “change” or “manage” I receive a message over a black screen that says “Application error: a client-side exception has occurred (see the browser console for more information).”

8 replies

Userlevel 7
Badge +4

Are you a new customer or are you an existing customer who tried to upgrade your phone?

As well, have you tried to log into self-serve using invisible mode or incognito mode?

Userlevel 7
Badge +4

@deanmp We tried to reach out to you this morning to help you with the address change.  Let us know when the best time to get in touch. We don’t want you to miss out saving money by shopping online!

Update: We see you were able to change address online and you submitted an order. Great to see everything worked out!

I am having the same problem! How is this resolved? 

Userlevel 7
Badge +4

@SinimonB Per our quick chat your new address has been updated and you can go ahead and upgrade that new shiny phone. 😀 Also, remember to check out the new Canada-US plan, only $5 more than your current plan but you do get 100gb data and no more worries about roaming in the US. It’s included!  Plan is only available to existing customers, pls log into your account to see more details. 

Also having this issue. Can’t change address. Maybe posting the solution would be better?

Userlevel 7
Badge +4

Hi @TMcLean 

We can see that you managed to make the change in self serve  and placed the order.


Let us know if you need help with anything else.

Same issue. Would be nice to post a solution rather than DM everyone privately. Obviously somewhat widespread.

Solution for me was to use Edge. Firefox and Chrome both have the same issue. 

What worked for me was opening in an incognito window @yewmii