Koodo Community
Question

my profile / self serve not loading


When I try and pull up mobile services it just gives me a blank screen


9 replies

Userlevel 7
Badge +4

When you first login does the page open properly? Hoe about when you go to the usage page? 

The page after logging in loads up. The usage page gives me the same blank screen. Same with everything else under self serve

Userlevel 7
Badge +4

Try clearing your browser's cache or trying another browser to see if that fixes things 

Yeah I’ve done that and tried it on 3 different browsers, would it be because my account is too new?

I will also add that even when I go to the “shop” after I am logged in it prompts me to select an account and from there I can’t do anything

Userlevel 7
Badge +4

Let me flag a rep for you 

Userlevel 6
Badge +4

@Edr96 Hi there! The reason you are not able to access your Koodo Self-Serve, its because you don’t actually have an active account. The migration from TELUS wasn’t completed yet. Once the migration and port is completed, you will have access to your Self-serve. 

Hope this helped.

Cheers,

I was told that process had failed and I had to wait for a sim card to do it manually. If I can’t access your website I how will I be able to do this when I receive the SIM card ?

Userlevel 6
Badge +4

@Edr96 , No worries! When you receive the SIM, you can call in and they will complete the activation of the SIM and your account at the same time since it's a migration from TELUS. 

Reply