Koodo Community
Question

Roaming not working. “No Service” of cellular in U.S.

  • 20 October 2021
  • 16 replies
  • 122 views

I am a new customer  of Koodo.  I switched over from Fido two days ago and now I’m travelling to San Francisco California. I get no service.  PLEASE HELP.! URGENT!  THANK YOU!!


16 replies

Userlevel 7
Badge +4

Is your account prepaid or postpaid?

I am a monthly customer, so my account is postpaid. Right?

I want to point out that my current phone number is one that I ported from Fido to Koodo. It is not the Koodo number assigned to me when I ordered the new SIM from Koodo.

Userlevel 7
Badge +4

@Kwanjkk It’s  the line ending with 75 that you are having challenges with right?

On our end everything looks alright from a porting perspective.  Looks like you brought your own phone. What I would suggest to try first is simply powering your phone off and on again.  Then go to the setting of your device look for ‘cellular’ and see if any network shows up there. Your phone is likely set for automatic selection but you could toggle to manual to see if it picks up signal from any of the networks we have agreements with for roaming.  

Since you mentioned you brought your phone from Fido, this post of ours can also be helpful to ensure proper APN settings:

https://www.koodomobile.com/en/help/setting-data-your-non-koodo-phone?search_api_views_article_search_fulltext=apn

Hi, 

Thanks for trying to help.

Yes, my current line number is ending with 75. 

I want to point out that my current phone number is one that I ported from Fido to Koodo. It is not the Koodo number assigned to me when I ordered the new SIM from Koodo. Koodo’s original number is 289 987 4253.

I activated the Koodo SIM on Monday.  I ported the number right then.  I am in the U.S. Tuesday. The …75 line works more than 24 hours in Toronto. As soon as I landed in San Francisco, I got no service. My iPhone did searching and return No Service after a minute or so. I did powered off / on my phone, try manual network selection, all the same result. I have also checked the APN settings. They matchs Koodo’s. Still, problem persists.

I have also checked my bill. I have also paid up.

Would Koodo need to work with US carrier regarding my ported number for roaming? Fido would have tell US  carriers to provide No Service to my …75 number? I am guessing.

 

Please help. Thanks. 

 

Everyone knows how frustrated when there is no cell phone service. Let alone when someone is travelling. :(

Userlevel 7
Badge +4

@Kwanjkk You account is in good standing. The fact you were able to use your phone without issues suggests the port from Fido went through no problem. The temporary number you were given has no bearing on the challenges at hand. No carrier has to notify US partners about roaming.  You brought your own phone when you opened the account which makes checking the device itself remotely not possible. Have you tried taking out the SIM and re-insert it?  Can you let us know if you can connect to wi-fi networks and not posting your messages here from a computer let’s say. Even with a SIM not working you should be able to. This way we could narrow down the potential source of issues. We will try our best and I totally get what it feels like when your have limited connection. If I could ask you to send us a private message on Facebook, we could further authenticate your account and possible recommend some steps. 

I just tried power the phone off, pulled out the SIM, reinserted the sim, turned the phone on,. The phone searched for carrier but returned No Service. I can use the phone on wifi network. But I hardly a Facebook user.

what else can we try to fix the problem?

Userlevel 7
Badge +4

...and what happens when you change the network selection mode from automatic to manual?

Userlevel 7
Badge +4

I just tried power the phone off, pulled out the SIM, reinserted the sim, turned the phone on,. The phone searched for carrier but returned No Service. I can use the phone on wifi network. But I hardly a Facebook user.

what else can we try to fix the problem?

Did you enable the International Voice Roaming add-on to your Self-Serve account?

Userlevel 7
Badge +4

I just tried power the phone off, pulled out the SIM, reinserted the sim, turned the phone on,. The phone searched for carrier but returned No Service. I can use the phone on wifi network. But I hardly a Facebook user.

what else can we try to fix the problem?

Did you enable the International Voice Roaming add-on to your Self-Serve account?

Not actually required for US roaming.

The network selection on the setting is on automatic and greyed
 

Below is the list of my add ons:

$13/day Easy Roam INTL

$0

$9/day US Easy Roam

$0

International Data Roaming

$0

International Voice Roaming

$0

Koodo VoLTE Access

$0

Outbound Calling Name Display

$0

Total add-ons per month

$0

Userlevel 7
Badge +4

So you can't turn the “automatic" setting off? If so there appears to be a problem with your phone.

Thank you very much, Timo, for pinpointed the problem. Too bad that the iphone has acted up unsuspiciously. I put the Koodo SIM card on another phone for trial. Then the sim is roaming ok and I got connected to a carrier now.

THANKS!

Hello, I am currently in the US and my data roaming and calling isnt working. Please help

Userlevel 7
Badge +4

Hello, I am currently in the US and my data roaming and calling isnt working. Please help

Have you tried any of the troubleshooting steps listed above? What happens when you do?

Thank you Timo. I changed the setting to manual netowork and its working. 

Reply