Koodo Community

Continuous errors when looking at usage

  • 6 July 2023
  • 6 replies

Does anyone else get continuous errors when looking at the usage page? I’d say it happens to me 70% of the time, regardless of which browser I am using, or if I’m on my laptop or mobile phone. 

Even more oddly when looking at Minutes for my partner and I it always shows the two phone numbers called/received as our own two numbers, even when we’ve called or received a call from another phone number. 

This topic has been closed for comments

6 replies

Yes even i am getting the same error 

Userlevel 7
Badge +4

I got that error sometimes. Normally a refresh of the weboage would help. As well, I tried the incognito mode. Regarding the number, I think it was a glitch. Hopefully they will fix it soon.

Hope for the best this is happening with me from past 2 months 

I have been having the same issue for the past several months.

I don't know why koodo is not doing anything to fix this issue.

I have two numbers on my account, they are only showing usage back to mayb14. The april-may cycle says not activity in that period for both phones. May-june it shows all calls are incoming from a local number (every call is from the same number) there are so many of them that I know I didn't receive or make as they are times when I was sleeping or in appointments. Some of those calls have charges on them but most of them don't, yet they are all incoming from the same number. The next cycle that we are currently in, june-july, it shows that all calls are from my number to a number that I know and have saved in my phone. Also, I know I didn't make any calls in most of the times showing. I spoke to Koodo yesterday to try to decipher a private caller that has been calling me in the middle of the night and he lied to me and said he couldn't see the usage for July 2 yet. He was lying to me, as I was finally able to get into my self serve after speaking with him and was able to see the calls myself. I have anxiety and am a very deep thinker so I started looking into different scams and hacks. I don't think it is glitch or an error, I am convinced it is some type of scam.