Koodo Community

Community

Solved

No 4g connection on Lumia 520?


Hi I have a Telus Lumia 520 working on the Koodo network. For some reason I only have 2G and 3G as selectable options for the network settings; no 4G. Why am I only getting 3G as the highest option? How do I get 4G?

7 replies

Userlevel 7
The Lumia 520 does not support 4G (aka LTE). HSPA maxes out at 21 mbps whereas HSPA+ hits 42 mbps. Currently only Telus/Koodo and Bell/Virgin networks support HSPA+.
Thanks. HSPA should still display an H+ icon, shouldn't it? I only get a 3G icon on the home screen
Userlevel 7
Badge +4
Ryan Peatt wrote:

Thanks. HSPA should still display an H+ icon, shouldn't it? I only get a 3G icon on the home screen

That's all I've ever got on the 520 is a 3g symbol
Userlevel 7
Ryan Peatt wrote:

Thanks. HSPA should still display an H+ icon, shouldn't it? I only get a 3G icon on the home screen

Yup me too 3g is all it'll display
Userlevel 7
Badge +4
Ryan Peatt wrote:

Thanks. HSPA should still display an H+ icon, shouldn't it? I only get a 3G icon on the home screen

I get H+ on my 520. Check your network settings.
Userlevel 7
Ryan Peatt wrote:

Thanks. HSPA should still display an H+ icon, shouldn't it? I only get a 3G icon on the home screen

Hmm going to try it later, I'm in Ontario in a 4glte area.
Userlevel 7
Badge +4
Install this app: http://julip.co/2012/12/lumia-810-change-apn/ It'll create a new menu in your settings. Select Koodo from the list. Even though it's a Koodo phone, this may help.

Reply