Koodo Community
Question

Issues with MMS (data/voice works) - looking for suggestions

  • 22 September 2022
  • 6 replies
  • 82 views

Hello, I’ve searched the forum but the results have not resolved this problem. I have been using an Essential PH-1 (Android 10 “Q”)  with Koodo for several years without issue, but a few days ago data stopped working (voice/SMS/RCS chat/Wi-Fi/Bluetooth are fine). After trying several other options, including resetting network settings and clearing caches, I was finally able to restore data by creating a new APN settings entry. The default page with “reset to default” uses the old IP address for the proxy, but I used settings from Koodo’s help pages and this forum. However, MMS still does not function for either send or receive; I get notifications to download but these cannot complete. Also, group MMS messages now arrive as if from individuals, again with the “download” option, even with the “group” option set in Messages.

I have tested the SIM in two other phones and it works, while a SIM from another, fully functional PH-1 with an identical Koodo plan exhibits the same issue when inserted in my phone. I would appreciate any suggestions as to where to look for settings and configurations that might cause this issue. 

 


6 replies

Userlevel 7
Badge +4

Next to the heading MMSC, it should read:  http://aliasredirect.net/proxy/mmsc

Try removing the word ‘koodo’ from that line to see if this works. Everything else in the APN appears to be set up correctly.

 

 

Thanks, I tried it again without “koodo” but no luck. MMS sends just sit there, incoming saying “downloading” but nothing happens. I’ve rebooted, powered down, even cleared cache. 

Userlevel 7
Badge +4

Thanks, I tried it again without “koodo” but no luck. MMS sends just sit there, incoming saying “downloading” but nothing happens. I’ve rebooted, powered down, even cleared cache. 

Try experimenting with the following APN settings.

APN Type: default,mms

APN Protocol: IPv4

MVNO value: 4B

Save your edits to the APN and reboot your Essential PH-1.

Thanks, I tried it again without “koodo” but no luck. MMS sends just sit there, incoming saying “downloading” but nothing happens. I’ve rebooted, powered down, even cleared cache. 

Try experimenting with the following APN settings.

APN Type: default,mms

APN Protocol: IPv4

MVNO value: 4B

Save your edits to the APN and reboot your Essential PH-1.

No luck, lists as “LTE” but no mobile data at all. Phone Info menu shows “Data service: Disconnected” and Messages says “Waiting for connection” when sending MMS.

Userlevel 7
Badge +4

No luck, lists as “LTE” but no mobile data at all. Phone Info menu shows “Data service: Disconnected” and Messages says “Waiting for connection” when sending MMS.

Very strange, indeed. A few questions.

Are you running a stock ROM?

Is it possible to switch to 4G or 3G from the Phone Information page under Set Preferred Network Type?

Under Developer Options (if you have Developer Mode enabled) is mobile data set to always active?

Edit: I did read your post on Reddit, guessing stock rom w/root.

 

No luck, lists as “LTE” but no mobile data at all. Phone Info menu shows “Data service: Disconnected” and Messages says “Waiting for connection” when sending MMS.

Very strange, indeed. A few questions.

Are you running a stock ROM?

Is it possible to switch to 4G or 3G from the Phone Information page under Set Preferred Network Type?

Under Developer Options (if you have Developer Mode enabled) is mobile data set to always active?

Edit: I did read your post on Reddit, guessing stock rom w/root.

 

Stock ROM, Android 10, rooted (with Magisk), configuration has not changed for at least a year or two. Root is specifically for AdAway (ad blocker), AFWall+ (firewall) and Titanium Backup. I’ve checked the firewall logs, completely disabled the firewall and ad filters, reflashed the modem, reset network settings, all to no avail. What’s really odd is that my spouse’s phone (PH-1 with same Koodo plan) has the old APN configuration with the IP address and it works properly.

I’m planning to either call Koodo or go to one of their booths, to see if perhaps there’s a glitch on their end. It might be a long shot but we did just have our plans changed due to Koodo’s recent $5 price increase for old Public Mobile migration accounts. 

Reply