Koodo Community
Question

Data and MMS on a non-Koodo phone (Xperia XZ2)


Hi there! I am running a Sony Xperia XZ2 - while I am able to make and receive calls, and connect to mobile data (at speeds maxing out at only about 10Mbps), I am unable to send (and likely receive) MMS text messages. When attempting, I see the message “MMS is not available on this network.” I have tried all the APN settings, including those listed by Kodoo (which didn’t solve the problem) - https://www.koodomobile.com/en/help/setting-data-your-non-koodo-phone and elsewhere - 
https://apn-canada.gishan.net/en/apn/koodo
https://www.4gapn.com/ca/en/koodo
https://techbiote.com/koodo-apn-settings/

Is there an updated, definitive set of network settings that I should be using, or is it possible there’s another reason I can’t do MMS (and that my data speed isn’t great)?

Thanks!

 


13 replies

Userlevel 7
Badge +4

Could you share some screenshots of your current APN settings?

Current settings. Ignore my previous comment about data speed as that is no longer an issue. 

Userlevel 7
Badge +4

And you’ve tried leaving Proxy and Port blank, changing MMSC to http://aliasredirect.net/proxy/mmsc and MMSC Proxy to mmscproxy.mobility.ca and MMS Port to 8799 ?

 

After you change toggle airplane mode on and off to see if that helps kick it in as well if you haven’t tried.

Thanks, Allan. I started with those same settings as listed by Koodo, but let me play around some more and I'll let you know when I get it working. 

Presently I have put all settings back to those specified by Koodo and I still can’t send MMS.

Userlevel 7
Badge +4

Presently I have put all settings back to those specified by Koodo and I still can’t send MMS.

Have you tried resetting your network settings?

Tried that. Then reinstated the default APN settings provided by Koodo. No dice.

Userlevel 7
Badge +4

Have you tried it with your SIM in another phone just to rule out some weird issue in your new phone? I have a Koodo phone and it works with all the default settings... Just a thought.

It seems unlikely that the singular issue of mms would be specific to my device, particularly when the error explicitly mentions the network. That said, nothing else has worked, so perhaps it's worth a shot. 

Userlevel 7
Badge +4

It seems unlikely that the singular issue of mms would be specific to my device, particularly when the error explicitly mentions the network. That said, nothing else has worked, so perhaps it's worth a shot. 

Can you show your current APN as of now (again)?

Someone mentioned in other thread with Oneplus device that he/she needed to delete all other APN and kept only one APN to make it work in that case. I think you could test that also.

I only have one. 

It uses the default Koodo settings. Here are the screens. 

 

Badge +4

Looking at your most recent screenshots, the MVNO type and value are not set when applying Koodo’s default APN settings. Tap the ‘MVNO type’ field and select GID from the dropdown menu.

After selecting GID, the ‘MVNO value’ field may auto-populate with an alphanumeric code. In your earlier screenshots, the MVNO value shows as 4B4F.  Tap the ‘MVNO value’ and remove the value, if any. Type in 4B then tap, OK. Save your APN Settings edits, then check to see if the issue is resolved.

While those values are not included in the settings listed by Koodo and I'm not sure how they relate to MMS, I did, as you said, have them in place before. The sequence of 4B4F should make no difference than 4B as it's just an order of reference. That said, I did follow your suggestion but, unfortunately, it changed nothing. I'm not sure what other options exist at this point but I thank you all for your assistance. 

Reply