Koodo Community

Coating peeling off of the ZTE hub

  • 17 September 2021
  • 7 replies
  • 59 views

It’s peeling off in chunks - feels like paint but maybe it’s plastic.  The phone still works fine, but I think I should tell someone; no?  Who?


7 replies

Userlevel 7
Badge +4

That weird.  Can you post some pictures?  WHen did you get the hub?  There should be a warranty on it

Userlevel 7
Badge +4

It’s peeling off in chunks - feels like paint but maybe it’s plastic.  The phone still works fine, but I think I should tell someone; no?  Who?

Assuming your hub is still within the one-year warranty, you can consider getting it repaired at an authorized service centre. http://zte.dfcomputer.ca/service

That weird.  Can you post some pictures?  WHen did you get the hub?  There should be a warranty on it

We got the hub in December 2019.

 

Userlevel 7
Badge +4

I believe they provided only 1 year warranty for the device. The device is out of warranty now. 

You could try to repair it https://www.koodomobile.com/en/help/warranty-and-repair-policy

However, the repair fee might be higher than the cost of a new replacement. I would suggest you keep using the old one (if everything is still working). 

Userlevel 7
Badge +4

Put some black tape on it. Should make it look like new :)

I thought there would be a problem when I returned it - but now it occurs to me that I may own the thing.  In that case, it does work so I guess this post was for entertainment purposes only.  :stuck_out_tongue_winking_eye:

Reply