Koodo Community

Community

Solved

Online Payment Not Working


Userlevel 1
I am unable to make a payment online, I inputed my information a few times (ensuring it was correct every time) and all it does is bring me back to the billing page and the amount doesn't seem to be taken. Online payment is he only mode of payment I use.

68 replies

Userlevel 7
Badge +4
Is the name the exact same as that on the account? If not it has to be so that may be your issue. If your using the online self serve then try using the app I never have problems using the app for payments.
Userlevel 7
Badge +4
@ Renee Are you using the same card as last month? I don't see your payment attempt on our end which suggest to me that it's your credit car issuer that temporarily, for reasons unknown to me that maybe the culprit. Let me know if you continue to have problems. 
Userlevel 1
Yes, I am using the same credit card I have been using for months which I used a few hours prior without any issues....
Userlevel 7
Badge +4
Renee T wrote:

Yes, I am using the same credit card I have been using for months which I used a few hours prior ...

If it just won't work, an alternate is to use online banking with your bank and add Koodo as a payee. It takes a few business days for the payment to show up, but it's not dependent on Koodo's payment site.
Userlevel 1
Renee T wrote:

Yes, I am using the same credit card I have been using for months which I used a few hours prior ...

Not an option. But thanks for the suggestion all the same.
Renee T wrote:

Yes, I am using the same credit card I have been using for months which I used a few hours prior ...

I am having the same trouble.....tried inputing the same card info I have used for the last year and it just kept returning me to the start.....same for me paying thru online is not an option.  Frustrating
Userlevel 7
Badge +4
Renee T wrote:

Yes, I am using the same credit card I have been using for months which I used a few hours prior ...

Hi Susan - we're experiencing some issues at the moment with our online payment method. You can still make payments through the IVR system by calling 611 from your phone, or through online banking.
Renee T wrote:

Yes, I am using the same credit card I have been using for months which I used a few hours prior ...

I was having the same problem, try paying through the Koodo app on your phone, that worked for me
Renee T wrote:

Yes, I am using the same credit card I have been using for months which I used a few hours prior ...

I'm having the same problem.  will not go past the page where you verify the information.  Everything has a green check mark, but does not proceed to the next page
Renee T wrote:

Yes, I am using the same credit card I have been using for months which I used a few hours prior ...

I'm having the same problem.  It was happening yesterday, I figured it must be a glitch.  Tried a few times again today and it's still happening. Very frustrating.
Userlevel 7
Badge +4
Renee T wrote:

Yes, I am using the same credit card I have been using for months which I used a few hours prior ...

Folks, pls use the automated 611 line or our Koodo while we are looking into this. Thanks for your incredible patience! Truly appreciated! 
Renee T wrote:

Yes, I am using the same credit card I have been using for months which I used a few hours prior ...

I tried a few days ago and today and the same thing happens to me. I enter the information and there is all green checks and then it flips right back to the beginning. What is our Koodo?

Userlevel 7
Badge +4
Renee T wrote:

Yes, I am using the same credit card I have been using for months which I used a few hours prior ...

Hi Ben - the issue was identified and a fix was put into place yesterday. You shouldn't be experiencing the same problem.. but if you are, can you provide some more details so we can further look into this? Are you using a card you've used before (does it pre-populate the info?) Are you entering certain/all info manually? What browser are you using? Mobile or desktop? Etc. If you can elaborate on the steps and what exactly is happening I'll share the info with our team to look into. Also, please try clearing the cache in your browser to be sure that isn't the browser.
Userlevel 7
Badge +4
Renee T wrote:

Yes, I am using the same credit card I have been using for months which I used a few hours prior ...

We are working on it Ben! It looks like only some customers are affected and we are trying to figure out why. In the meantime pls dial #123 from your phone, option 3 to make a payment. Alternatively you can use our app as well. Thanks for your patience!
Renee T wrote:

Yes, I am using the same credit card I have been using for months which I used a few hours prior ...

I'm having the same issue. Have been trying to pay and no joy. Same name. Same method of payment. Same computer...
Renee T wrote:

Yes, I am using the same credit card I have been using for months which I used a few hours prior ...

I have had the same issue for the last week and was expecting the Koodo will cut me off in 24-48 hours message, however I went outside of my phone app and went old school on the basic Koodo website and payment was accepted immediately
Renee T wrote:

Yes, I am using the same credit card I have been using for months which I used a few hours prior ...

I have had the same problem today.  I've tried re-inputting my info several times and it is like being on a merry-go-round.  It will not process my payment.  Please fix!

Userlevel 7
Badge +4
Renee T wrote:

Yes, I am using the same credit card I have been using for months which I used a few hours prior ...

Thanks for reporting. I've shard this with the team looking into the issue to let them know it still exists. If you're able to share any more info. by elaborating on specific steps or providing screen grabs of what you're seeing, that would be helpful as well. 
Renee T wrote:

Yes, I am using the same credit card I have been using for months which I used a few hours prior ...

same for me. I have been trying to pay online and it doesn't work. I've been doing it for the past 2 years without a problem...

Userlevel 7
Badge +4
Renee T wrote:

Yes, I am using the same credit card I have been using for months which I used a few hours prior ...

Looking at your account it doesn't look like you got to the step of submitting payment on you Visa. Was there an error message you received by any chance? I would recommend you dial #123 and press 3 for payment if you continue to have an issue Christine. The phone option is also automated and just as easy. 
It's not working for me either.  When a make the payment, I don't get any errors, it just brings me back to the payment first step where I have to input my info again.  Endless loop.
Marc Light wrote:

It's not working for me either.  When a make the payment, I don't get any errors, it just br...

exactly!

Marc Light wrote:

It's not working for me either.  When a make the payment, I don't get any errors, it just br...

Yup. same here.
Marc Light wrote:

It's not working for me either.  When a make the payment, I don't get any errors, it just br...

Same for me on this November bill.
Userlevel 7
Badge +4
Marc Light wrote:

It's not working for me either.  When a make the payment, I don't get any errors, it just br...

I see you reported a payment via the automated phone process Doug but no payment was actually made. Are you saying you are having an issue online? 

Reply