Koodo Community

Community

Solved

Login Issues


I have already registered with the self serve options, I am no longer able to login. It continues to say that the website is not working or I have been redirected too many times. I have tried two devices and two browsers. I cannot use the mobile app as I need to provide myself permission to use it.... I have cleared the cookies, restarted browsers, blah blah blah... I'm out of ideas When I was actually logged into the account I wasn't able to access any information about my account - no usage information, not the account number nothing. All it would allow me to do it change the email address, password and security question... I thought the telus mobile site we tedious but damn...

3 replies

Userlevel 4
It seems to be one of those time when you need to call *611 and talk to a Koodo rep.
Userlevel 7
Badge +4
Sometimes the website can be finicky. Its working fine for me so it could be an issue your not noticing as well. I would try again in the morning and if its still not working, Most likely contacting customer care is your best bet.
Userlevel 6
Hey Colleen! Is there another email associated with your account? You can always try clearing the cookies/cache and try again.  Also, try logging in using this link http://koo.do/1sA1y6Q . Let us know if it works! 

Reply