Koodo Community
Solved

Can't activate call control

  • 5 February 2021
  • 7 replies
  • 72 views

I get an average of 1 SCAM call per hour, I don’t really need a voice plan, so I’m looking for something like a pager. But in the meantime, I’d like to enable call control. Not that 25 blocked numbers are going to help me. I just stopped answering my phone. Which I’m fine with, I just don’t like hearing my phone ring every hour because of some waste of human resources. 


sadly on both the app, and the browser, clicking enable call control does nothing at all.

Suggestions?
I’ve tried Edge, Firefox, and Chrome, all have the same results. 

icon

Best answer by Sophia 5 February 2021, 00:55

I forgot though that the new $15 plan includes 100 minutes, so that doesn’t really help you either. You could still be called… Sorry :(

What about a tablet plan? Or just leave your phone on DND for incoming calls? I know it’s a nuisance, we don’t get them as often as you but once a day is quite irritating already!

View original

7 replies

Userlevel 7
Badge +4

You can enable spam filtering in self serve, if you have a postpaid plan. It’s not available for me on prepaid so I can’t tell you exactly where to find it, but holler if you need help.

You should also sign yourself up with the Do Not Call register here: https://lnnte-dncl.gc.ca/en - and many phones have built in spam filtering. I have a Samsung and it uses Hiya for free.

Last resort is to change your number but unfortunately, I don’t think there are any “safe” numbers nowadays so chances are you’ll just get spammed again.

Oh one last possibility is the $15 prepaid plan. You can still text and buy data boosters, but if you don’t buy a booster for minutes, you’ll never be bothered again :)

There is no such option available for me in “Self Serve”. I have a Postpaid plan.

I’ve also signed up for that DNC service countless times. It’s of no use when combating spoofed numbers from scammers.

I already use Hiya, however, it’s not effective against spoofed numbers and is currently broken in the latest Samsung Update.

The $15 plan sounds like the best option so far. 

Thank you.

Userlevel 7
Badge +4

I forgot though that the new $15 plan includes 100 minutes, so that doesn’t really help you either. You could still be called… Sorry :(

What about a tablet plan? Or just leave your phone on DND for incoming calls? I know it’s a nuisance, we don’t get them as often as you but once a day is quite irritating already!

I was previously using DND, however, that feature seemed to have disappeared from my phone  (Samsung Galaxy A50) after an update and I started getting calls again.

I have “Block unknown/hidden numbers” enabled. As well as “Block spam and scam calls” which again is ineffective when they’re spoofing numbers. Also for some reason, even though I have set it as “Block all spam and scam calls”, it takes a few tries to get it to set correctly to that vs the high risk only.

I can add numbers here, though sadly no prefix blocking.

Also, I was curious about the “Customization service” under “other call settings”, but when I tap it to obtain more information, it tells me I’m too young to use the service…let’s just say I’m far from it. Gave me a laugh though.

I suppose “Call barring” might be an option if set to “All incoming calls” that should allow texts through I assume.

EDIT: Nope, Call barring failed.
It asks me for a password, I enter my password? it says

Failed to read data
Call barring rejected.

 

Userlevel 7
Badge +4

Well I’m not on a postpaid plan myself, but someone mentioned that it should be under 'Mobile Services' from the Self Serve menu in the nav (Koodo self serve website) and then the last option:

 

 

Does that help you any? Can you access that feature?

Nope. No such item. The last item is “Call Control”, which has magically started working.

 

Userlevel 7
Badge +4

I assume that's the one... Fingers crossed that'll keep the bad guys out!

Reply