Koodo Community

Community

Solved

"This voucher has already been used" WHAT? No it hasn't! Where's my money?


I purchased two top-up vouchers this afternoon. One for $50 and one for $25. When I got home I logged into my Koodo self-serve account and added the $50 voucher with no problem but when I entered the $25 voucher I got a message that the voucher had already been used but the funds where not added to my account! I tried entering the PIN number several times, and I was very careful to enter it correctly, but I kept getting the same message, that the voucher had already by used, and then after 4 or 5 tries I was locked out, I can't enter any more top-up PINs for 24 hours. I would appreciate some assistance with the problem, I don't think I should have to pay $10 for help with an issue like this.

4 replies

Userlevel 7
Badge +4
Give Koodo a call. It's no charge since it's an issue that you cannot solve on your own via self serve
Userlevel 7
There's no charge to call customer service for issues like this since it's evidently out of your control.
I will. Thanks!
Called *611 and spoke to Carlos. Problem solved! Very happy.

Reply