Koodo Community

On going issues with logging into the prepaid service.

  • 6 November 2015
  • 2 replies

Since signing up for Koodo, I have only been able to log into my prepaid account once, which was to set up the account itself. Since then, every time I go to log in, I get the same error; Generic ErrorOh no! 
It looks like something went wrong, but don’t panic.

Log out and then log back in again to continue. Or return to the Login Page.

And when I click on the link to go to back to the login page, the same thing comes right back. I have tried different browsers and I get the same error, and my self serve on my phone will not let me log in at all. Hopefully someone can suggest something to assist me with this or at least let me know if the site itself is down or not.

2 replies

I've got till the 16th before I have to pay again for the new month, but it's kinda of disheartening that it's been going on for almost a month now.
Userlevel 6
Hey mate.
There are actually several threads on this issue already.

It is being investigated and fixed.
You can call into customer service to make any changes and this will be a free call when you explain that you are having issues with the self serve site.

Hang in there, a solution is on the way.