Koodo Community

Community

Nexus 6P - can't do MMS after Oreo update?


I don't have a data plan and don't want one. I had a data booster for awhile, didn't really use, but it eventually ran out.  MMS has always worked before and during data booster. After data booster runs out I have not been able to send or receive MMS messages.   I have a (permanent?) notification that my "Mobile data has run out" from MobileCarrier app.  (And lots of "failed to downolad MMS - turn on mobile data" from Chomp or Android stock messaging app - tried both.)  Any ideas? (Other than factory reset suggested in another similar post with no resolution..)

14 replies

Userlevel 7
Badge +4
Is your data turned on on your phone? This needs to be enabled in order to send mms
Yes. I have used mms without data for a couple of years. Used a data plan once, now that it is done I have the issue. Data is on. Tried turning off an on. Tried airplane mode on then off. Tried restarting phone. Tried leaving phone off for awhile then back on. Tried taking sim out and then back on. 

I think the problem lies with me not being able to get rid of the "Mobile Carrier" app telling me that my "Mobile data has run out" and "Tap to visit the Koodo website".  I don't want to add more data - I just want MMS to work again.

Userlevel 7
Badge +4
sean wrote:

Yes. I have used mms without data for a couple of years. Used a data plan once, now that it is do...

Are you able to to mms on the default messaging app?
I did try the stock Messaging app but still can't send MMS.
Userlevel 7
Badge +4
sean wrote:

I did try the stock Messaging app but still can't send MMS.

You mentioned about the "Mobile Carrier" app blocking something. Koodo retired their mobile app already. Where was that program from?

sean wrote:

I did try the stock Messaging app but still can't send MMS.

Not sure. Not in app list from Play store. When I long press on the notification (that I can't swipe away) it says "CarrierDefaultApp" and more settings brings me to the attached image.

Userlevel 7
Badge +4
sean wrote:

I did try the stock Messaging app but still can't send MMS.

It looks like an app from Android Oreo itself. I don't have an Android with Oreo, so I am not sure how to deal with it. However, some reported that Oreo disable data mobile on  Pixel and Nexus in Android forum https://productforums.google.com/forum/#!topic/phone-by-google/kw3ZcXd1BVs

There were also some reports there suggesting users to reset the APN again could help. I would suggest you reset the Koodo APN again. Hope it could do something
Tried resetting. Read through that whole link, but supposed to be fixed in November. Nothing can be done from Koodo? (Except I buy more data? Which I shouldn't have to do...)
Userlevel 7
Badge +4
sean wrote:

Tried resetting. Read through that whole link, but supposed to be fixed in November. Nothing can ...

You could try to call them and ask the technical support at Koodo
So Oreo 8.1 came out and solved my mms issue...but now I constantly get a different message from Android System, " Sign into network. Koodo". Better...mms works. Annoying notification now. Is this stoppable by Koodo? Or still Android?
Userlevel 7
sean wrote:

So Oreo 8.1 came out and solved my mms issue...but now I constantly get a different message from ...

Can you swipe it to the side and press the gear? It should allow you to block notifications coming from that app.
Nope. Android System app. "Notification from this app can't be turned off" If Koodo can't do anything then I guess I'm stuck hoping 8.2 to fix it? Can Koodo "tell" my phone that I'm signed on to network?
Userlevel 7
Badge +4
sean wrote:

Nope. Android System app. "Notification from this app can't be turned off" If Koodo can't do ...

It could be some setting incompatibilities between google and koodo/telus. I would double check the APN settings in your 6P, Google might change something there.

I would also suggest you put in another SIM from another carrier to see if it behaves similarly. Then reinsert your SIM.
APN settings match, but all greyed out and can't edit anyway. Don't have another SIM card handy, but I guess I'll ask someone.

Reply