Koodo Community

Community

Solved

I have data enabled on Moto g but cant send or recieve pictures!


I just activated my Moto G with the $15 Prepaid Plan and can't for the life of me get the mms to send and receive, sms works fine! I have read multiple posts and tried changing the APN but when I save it doesn't show up in the menu. Data is enabled on the phone.

18 replies

Userlevel 7
Badge +4
Hey there Scott. The question you need to ask yourself is : do you have data on your plan? Without data, you can't send MMSs
No I don't have data. Are you telling me that for my unlimited text and picture plan, I have to pay for data?
Userlevel 7
Badge +4
Unfortunately, Scott. Yes, this is what I'm telling you. I know Koodo advertises unlimited MMS but it's with non-smartphone... I'm not agreeing with this neither.
Userlevel 7
I might be wrong, but I thought on prepaid, you can send mms just by leaving data enabled without a data booster as for post paid Robert is correct. Scott, did you get the phone from koodo or elsewhere? Also try a battery pull out.
Userlevel 7
Badge +4
Daniel Kim wrote:

I might be wrong, but I thought on prepaid, you can send mms just by leaving data enabled without...

That is correct Daniel. You do not need to have a data booster for the MMS to work on prepaid.
I bought it from someone used, he purchased it from koodo. I just bought the new prepaid Sim for it yesterday.
Userlevel 7
Badge +4
scottgommer . wrote:

I bought it from someone used, he purchased it from koodo. I just bought the new prepaid Sim fo...

Daniel is correct, Scott, your picture messaging should definitely work on prepaid even without a data booster. Did you check if the APN settings are correct? http://aide.koodomobile.com/Portals/0/Phones/PDFFiles/Android.pdf
scottgommer . wrote:

I bought it from someone used, he purchased it from koodo. I just bought the new prepaid Sim fo...

It won't let me change the apn setting, after I change them and hit save they aren't available on the list only the original is available.
Userlevel 7
Badge +4
scottgommer . wrote:

I bought it from someone used, he purchased it from koodo. I just bought the new prepaid Sim fo...

Is the original different from the settings from that link, Scott? If so, create a new APN and activate that. If it's the same, then we'll have to troubleshoot some more 🙂
I bought it from someone used, he purchased it from koodo. I just bought the new prepaid Sim for it yesterday.
Settings are the same as the link.
Userlevel 7
Badge +4
scottgommer . wrote:

Settings are the same as the link.

Ok, let's see if we can find the solution for you... first of all, can you send text messages? Edit, oops I see you already said that in your first post, sorry. Second question then 😃 Did the sender use the address xxxyyyzzzz@msg.koodomobile.com to send you an MMS? And you did not receive it? Third question: did you port in your number from another provider?
scottgommer . wrote:

Settings are the same as the link.

Yes, sms send and receive fine but mms won't.
Userlevel 7
Badge +4
scottgommer . wrote:

Settings are the same as the link.

I don't quite understand, but that might be because I confused matters by changing my post, sorry about that lol. Can you please answer the second and third question Scott?
Userlevel 7
Badge +4
scottgommer . wrote:

Settings are the same as the link.

If you can't get it to work, you may need to call Koodo (*611) to see if it's something on their end 🙂
scottgommer . wrote:

Settings are the same as the link.

The message was sent to my phone number. My number was ported from telus.
Userlevel 7
Badge +4
scottgommer . wrote:

Settings are the same as the link.

Ah, I see. Sometimes when a number is ported in, it takes a little while for messaging to start working properly. You may need to call Koodo to sort it out, if all the settings are correct. Just to verify, you said the message was sent to your phone number. It would need to be sent to your phone number plus "@msg.koodomobile.com", as I said to xxxyyyzzzz@msg.koodomobile.com where xxxyyyzzzz is your number without the 1 in front... is that where it was sent to?
scottgommer . wrote:

Settings are the same as the link.

I have resolved this issue, it is because where I live, as soon as I move to where 3g or h+appear the mms sends!

Reply