Koodo Community

Community

Solved

Cant connect to koodo network xperia U


Hello,
I have a new unlocked xperia U.  Here what it say on the box:
GSM/GPRS/EDGE 850/900/1800/1900 & UMTS HSPA Bands 1/8
But when I put my sim card in, it does not connect to koodo network.  I'm I missing something?

12 replies

Userlevel 5
This device will only work on 3G.
Try setting your preferred networks to HSPA only or wcdma only
Koodo does not have 2G or Edge
Userlevel 3
Still trying to fully understand how this works myself but I'm pretty sure you need both 1900 and 2100 bands to work with Koodo. Looks like this phone is missing the 2100 band
Userlevel 5
You need 850/1900 for 3G network

LTE uses 1700/2100
Userlevel 3
Spence wrote:

You need 850/1900 for 3G network

LTE uses 1700/2100

for most devices do you have to manually select the 3G network or will it automatically detect connect?
Userlevel 5
This phone came out over 3 years ago,  under powered for 2015
Userlevel 7
Badge +4


Userlevel 5
Jocelyn,  are you getting an error of any sort about the SIM ?
ie: sim not detected , or enter carrier code , or no service

Ha!  thank you for reminding me that the phone is old!  But I like small phone and they are today bigger and bigger!
Well, I do get that sim error, depending on the menu I'm looking at.  When I try to manually connect to a network, I can sometime see a network names EXT 2G
Userlevel 5
Jocelyn Gagné wrote:

Ha!  thank you for reminding me that the phone is old!  But I like small phone and they...

2G will not work on Koodo.
Can you find preferred network in your settings
Jocelyn Gagné wrote:

Ha!  thank you for reminding me that the phone is old!  But I like small phone and they...

I can see there either GSM, WCDMA, or both
Userlevel 5
Jocelyn Gagné wrote:

Ha!  thank you for reminding me that the phone is old!  But I like small phone and they...

It should work on WCDMA only
Jocelyn Gagné wrote:

Ha!  thank you for reminding me that the phone is old!  But I like small phone and they...

well, my old A341 connect right away to kodoo...  Maybe there's a setting somewhere I'm missing.  Thanks for your help

Reply