Koodo Community
Solved

Wifi calling not turning on BYOD - Samsung A5 from Telus

  • 21 September 2020
  • 11 replies
  • 179 views

Hi team, I’m trying to bring over my Telus A5 but I go through the process of enabling wifi calling, get the registration text, and set my e911 up, however the icon never enables.

I have talked to a Rep, and they suggested to shutdown the phone and reboot it a few times now that it registered, however, the next day this still is not turning on.

Does Koodo allow Wifi-calling from non-koodo phones? It seems like a carrier restriction to me that is not clearly communicated on the sales page.

icon

Best answer by Dinh 21 September 2020, 21:03

I have the telus sim in now, and within 30seconds of flipping SIMs wifi calling is up and working.

VoLTE is also enabled in the SelfServe portal.

 

I’m also getting that MMI code problem with the telus SIM
something seems weird here.

As for reception, I live in the middle of the mountains, so I only get enough bars to more than voicemail notification ontop of my stove, and a phone sized corner of my coffee table.


Samsung used CSC code to control the carrier device for Wifi calling.

If your phone CSC code was still set to “TLS”, Koodo wifi calling wouldn’t work. You need to change it to KDO. You could search similar topic on Samsung device and wifi calling in the forum.

This link in TElus forum might also help https://forum.telus.com/t5/Mobility-Services/TELUS-does-not-support-VOLTE-for-unlocked-Note-8-That-is-very/td-p/77533

View original

11 replies

Userlevel 7

The responses to a similar question (specific to Pixel 3 but may still be relevant to Samsung A5) in the following link, may help https://community.koodomobile.com/android-81490/can-t-enable-wi-fi-calling-on-pixel-3-7795362

 

that 4636 code wasn’ working, but I found the other #*#4636#*# but thats giving me an error:

USSD code running…

Followed by

Connection Problem or Invalid MMI Code

 

Userlevel 7
Badge +4

When the phone was on Telus network, did it work with the same wifi network and at that location? 

It seems you got everything setup properly from your description. Koodo wifi calling put priority in cellular network so it only turns on when you are in bad cellular reception area and you have a compatible wifi network. I would check if that was the case. 

Btw, when you sign into your self serve, did you see volte access add-on in your account? 

I have the telus sim in now, and within 30seconds of flipping SIMs wifi calling is up and working.

VoLTE is also enabled in the SelfServe portal.

 

I’m also getting that MMI code problem with the telus SIM
something seems weird here.

As for reception, I live in the middle of the mountains, so I only get enough bars to more than voicemail notification ontop of my stove, and a phone sized corner of my coffee table.

Userlevel 7

The info in the link above may have been only applicable to Pixel 3.  You may find (IMS registration) info from other Samsung A5 users who encountered similar issues, by searching the internet.  I do not use Wi-Fi calling and have  reached the limit of my knowledge on this topic.  Good luck! 

 

Userlevel 7
Badge +4

I have the telus sim in now, and within 30seconds of flipping SIMs wifi calling is up and working.

VoLTE is also enabled in the SelfServe portal.

 

I’m also getting that MMI code problem with the telus SIM
something seems weird here.

As for reception, I live in the middle of the mountains, so I only get enough bars to more than voicemail notification ontop of my stove, and a phone sized corner of my coffee table.


Samsung used CSC code to control the carrier device for Wifi calling.

If your phone CSC code was still set to “TLS”, Koodo wifi calling wouldn’t work. You need to change it to KDO. You could search similar topic on Samsung device and wifi calling in the forum.

This link in TElus forum might also help https://forum.telus.com/t5/Mobility-Services/TELUS-does-not-support-VOLTE-for-unlocked-Note-8-That-is-very/td-p/77533

Badge +4

On some Samsung phones, the MMI codes *#*#4636#*#* or *#*#46368676#*#* allow access to the hidden Phone Information menu where you can view the IMS status for W-Fi calling. If the code is not entered exactly as shown, you’ll get an MMI error message. Some Samsung and other Android phones have dropped hidden menu accessibility, entirely. 

The CSC code should automatically change from TLS to KDO when a Koodo SIM card is inserted into your phone. To find the CSC code, dial *#1234#. Next to CSC, you should see a string of alphanumeric characters. The first set of characters is the phones’ model number. The second set of characters should show either KDO (Koodo) or TLS (TELUS) depending on which SIM card is inserted.

Ok that worked, I should’ve double checked what switching the CSC with the *#272*IME would do, but after it factory reset my phone, it came up and turned on as soon as I made it through the OOTB setup.

 

On some Samsung phones, the MMI codes *#*#4636#*#* or *#*#46368676#*#* allow access to the hidden Phone Information menu where you can view the IMS status for W-Fi calling. If the code is not entered exactly as shown, you’ll get an MMI error message. Some Samsung and other Android phones have dropped hidden menu accessibility, entirely. 

The CSC code should automatically change from TLS to KDO when a Koodo SIM card is inserted into your phone. To find the CSC code, dial *#1234#. Next to CSC, you should see a string of alphanumeric characters. The first set of characters is the phones’ model number. The second set of characters should show either KDO (Koodo) or TLS (TELUS) depending on which SIM card is inserted.


These codes were disabled on my Telus A5, the #*# one would just error out, and the *#*# one would just dial… not open the menu.
Changing the CSC with the *#272 code while it factory reset my phone, fired everything right back up. I wish there was a better way to change that code other than the factory reset though.

Badge +4

@GPhillips Not to make a big deal out of this, but MMI codes usually begin with an asterisk and a pound symbol (*#).  I’m not sure which code you’re referring to when you mention #*#. Again, not a big deal and I’m happy to hear Dinh’s solution worked and everything is up and running!:slight_smile: 

@GPhillips Not to make a big deal out of this, but MMI codes usually begin with an asterisk and a pound symbol (*#).  I’m not sure which code you’re referring to when you mention #*#. Again, not a big deal and I’m happy to hear Dinh’s solution worked and everything is up and running!:slight_smile: 


Like I said, the *#*#4634#*#*# code just… dialed.. no menu
I suspect its a Telus restriction, but we’re all good now :)

Reply