Koodo Community

Plan change not


I am trying to change my plan but it keeps saying  "Sorry that didnt worked please use assistant..." but when i do ot is tye same process but i just end up whith "Sorry this service is not available" I tried deletin the cache of my browser but nothing.What can i do ?


5 replies

Userlevel 7
Badge +4

A picture would worth thousand words. If possible, can you post a snapshot of the error here? (without any personal information please).

You could also contact Koodo directly and ask a rep to assist if you cannot do with within your self-serve.

And when i go through the assistant i see an ice cream cone saying its not available for the moment...its been two days and i busted my date in the day

-

Userlevel 7
Badge +4

It was obviously something wrong with the plan change and they were aware of it (and probarly fixing it). You could follow their instruction and get your plan changed. Go here www.koodo.com/chat and type #helpss If you don’t want a callback, you can chat with a rep via facebook/Twitter https://www.facebook.com/Koodo

I scheduled a call and got proper help.There was a couple  issues with the system which got resolved fairly quick despite them being busy at the moment.Customer service was great and everything is fine now.Thanks 

Reply