Koodo Community

Community

Solved

phone not working while traveling


I'm in South Africa, I purchased the International plan but when I dial +1xxx xxx xxxx I get a message saying I am barred from outbound calling. And my texts aren't going through or coming in. Any solutions? I can't even contact Koodo for help

3 replies

Userlevel 7
Badge +4
Sign into the koodo self serve website. Add the free "international voice roaming" add on. Then turn airplane mode on and off. When your phone connects it should be working.
Userlevel 7
Badge +4
On the other hand, is data roaming enabled on your phone?

To complete Timo's answer, here's how to add the free international roaming packages. There's two of them : 

Connect to sell serve and go to your add-ons



Click to change the add-ons



Search for 1) International Voice Roaming and 2) International Data Roaming



Userlevel 7
Try texting yourself to see if text messages are going through.

Reply