Koodo Community

Community

Solved

International data not working


I added the 40$ international bundle and the phone and texting works but not the data. Ive tried resetting my phone and i have my data on but it still doesnt work. Anyone know how to fix my problem?

11 replies

Userlevel 7
Badge +4
There may be a second setting to turn [i]data roaming off and on as opposed to just [i]mobile data.

1. On some Android phones: Settings=>More networks=>Mobile networks=> make sure Mobile data is checked, which you have already done.

2. In the same window, Network mode => LTE/WCDMA/GSM should be selected while you are on Koodo at home. You can toggle the values and re-start your phone. Sometimes this will fix your problem depending on your local service.
BobTheElectrician wrote:

There may be a second setting to turn [i]data roaming off and on as opposed to just [i]mobile...

Ive already tried both of those suggestions before hand and it still didnt work. Thank you for the reply.
Userlevel 7
Badge +4
BobTheElectrician wrote:

There may be a second setting to turn [i]data roaming off and on as opposed to just [i]mobile...

Did you add the data international roaming add-on in self-serve ?
Userlevel 7
Badge +4
BobTheElectrician wrote:

There may be a second setting to turn [i]data roaming off and on as opposed to just [i]mobile...

Check your plan add-ons in self-serve. Enable international voice roaming and international data roaming then restart the phone. Some people have complained they can’t find one or the other add-ons by using the Koodo app on the phone itself. In that case, use your browser and connect to self-serve that way. Both are listed at $0 per month and are needed in order to make any kind of connection outside North America.

Userlevel 7
Badge +4
@ Phoenix, can you put your phone on airplane mode and back please? Looked at your account and fixed what I think was causing the issue. Should work now.
I am having the same problem as Phoenix. Have tried everything that I could think of plus the suggestions made by BobtheElectrian. I am currently in France and the lack of data roaming is an issue. Any suggestions would be appreciated.
Userlevel 7
Badge +4
Alan Baker wrote:

I am having the same problem as Phoenix. Have tried everything that I could think of plus the su...

If you're looking for data, I suggest unlocking your phone and getting this: http://mobile.free.fr/
Userlevel 7
Badge +4
@ Alan, toggle your phone to airplane mode and back. I made a quick fix to your settings. Should work now.
Thanks very much - it's working. This is going to save me money as now I don't have to go into a brasserie and order a beer to use my phone. In laymen's terms could you explain the solution and will I need to do this whenever I am overseas?
Userlevel 7
Badge +4
Alan Baker wrote:

Thanks very much - it's working. This is going to save me money as now I don't have to go into a...

In order to access voice & data internationally you need to enable it. The voice portion was enabled. The data wasn't. It's a free feature (separate from the roaming add-on) that is available in self-serve. Now that it is on though, you will not have to be concerned for future travels. That said, I would strongly encourage consumption of local beverages to make your trips wholesome. :-) 
Alan Baker wrote:

Thanks very much - it's working. This is going to save me money as now I don't have to go into a...

I actually did try to enable that feature but was unable to. Thanks for the help. .

Reply