Koodo Community

Community

I phone says no service is there a simple fix?


I have an i phone 4 and since last night it is saying no service! My phone is new to me so im not sure if it is something simple i could do to fix this but am looking for a little help! Thank you in advance

20 replies

Userlevel 7
Badge +4
Have you tried rebooting the phone? Try toggling airplane mode as well.
Userlevel 7
Badge +4
Did you play with the settings?
Userlevel 7
Where did you get your phone?
Userlevel 7
Badge +4
Also make sure that 3G is not turned off.
Userlevel 7
Badge +4
Did the phone work with you before?
Dennis wrote:

Did the phone work with you before?

yes i got it from a friend a week ago and it worked well up until yesterday morning!

Userlevel 7
Badge +4
Dennis wrote:

Did the phone work with you before?

Did you use another phone before this iphone?

DOes you sim card work on this previous phone?
Userlevel 7
You can find your IMEI number in the settings, under General I believe. Enter it here, if it comes out with nothing then you should be fine but if you get an error, let us know what it is and we can help you from there.

http://help.koodomobile.com/getting-started-with-koodo/sim-cards-and-non-koodo-phones/how-do-i-know-...
I have a brand new LG G4 worked fine for 2 weeks and I have no service too since last night
Userlevel 7
Badge +4
Jeff Prevost wrote:

I have a brand new LG G4 worked fine for 2 weeks and I have no service too since last night

Have you tried the suggestions above?
Jeff Prevost wrote:

I have a brand new LG G4 worked fine for 2 weeks and I have no service too since last night

My phone has had no service for the last 4 days. I thought it was my phone cuz it was a little older. I bought a new phone and I still have no service. Everything works on my phone fine expect texting and calling.
Userlevel 7
Badge +4
Jeff Prevost wrote:

I have a brand new LG G4 worked fine for 2 weeks and I have no service too since last night

Hi Michelle,
Have you checked your selfserve and see if your account was active? and the new phone was compatible with Koodo net work?
If the account was active, then the problem could be the SIM.
Jeff Prevost wrote:

I have a brand new LG G4 worked fine for 2 weeks and I have no service too since last night

My older phone i know everything was active and sims card is fine. How ever you are right about my sim card for my new phone. I left the store thinking i was going to pop my old sim card in my new phone but no it is to big. My phone is compatiable with Koodo. Still doesn't explain why my other phone doesnt work
Userlevel 7
Badge +4
Jeff Prevost wrote:

I have a brand new LG G4 worked fine for 2 weeks and I have no service too since last night

I am a little confused, so your older phone worked with the "bigger" SIM?

When you bought the new phone did the agent give you a new SIM? They could have switched the old SIM into the new SIM. Have you tried the new SIM into the new phone?
Jeff Prevost wrote:

I have a brand new LG G4 worked fine for 2 weeks and I have no service too since last night

My old phone is the one with the bigger size sim card which worked fine. The new phone which is an unlocked phone came with a new sim card in the box. Your absolutely right that i should have had them switch it because then i would have know that my old sim card one was to big. So i have to go back to have it activated. What would be the problem with my old phone it was working fine 3 days ago?
Userlevel 7
Badge +4
Jeff Prevost wrote:

I have a brand new LG G4 worked fine for 2 weeks and I have no service too since last night

Can you try to take out the 'new SIM' and put into the new phone and see if it works.They could have switched for you already, as the old SIM was disabled 3days ago.

If it doesn't work, you could choose either to go back to the store or call Koodo to get them switch SIM.
Jeff Prevost wrote:

I have a brand new LG G4 worked fine for 2 weeks and I have no service too since last night

I did put the new one in. Looks like I am going back to the store to have them activate it. So i can understand why my new phone doesnt work but why doesnt my phone that has always worked doesn't. That is what i really want help with.
Userlevel 7
Badge +4
Jeff Prevost wrote:

I have a brand new LG G4 worked fine for 2 weeks and I have no service too since last night

If you SIM was suddenly disabled (no call, no text) after a new upgrade, there was a highly chance that your SIM was switched. I don't understand why your new SIM didn't work. It could be something wrong at the store.

Let us know if you can resolve the problem at store.
Userlevel 7
Badge +4
Jeff Prevost wrote:

I have a brand new LG G4 worked fine for 2 weeks and I have no service too since last night

It is a little difficult to determine why your old phone does not work.

It could be your device just died or it could be a sim issue .  Or it could be an account payment issue, but I hope the kiosk would have told you that if that was the case.

To diagnose the old phone you will need to test another working sim into your old phone to determine if it is a phone or sim issue.  Or even try your old sim into another working phone.  This assumes the sim fits the phone
if everything is fine and the phone just lost connection, you can go to 
1- Settings 
2- General
3- Reset network settings. 

Reply