Koodo Community

Community

I have travelled from Canada to U.K. and have brought the add on but still cannot make a call


10 replies

Userlevel 7
Badge +4
Sign into the Koodo self serve website.  Make sure you have added the free “International Voice Roaming" and / or the free “International Data Roaming” add on. Also make sure Pay-per-use International Long Distance is active. Then turn airplane mode on and off. When your phone connects it should be working. Buying any of the Travel Add-ons on a postpaid plan only nets you a savings on your roaming fees, it does not change anything about the ability of the phone to roam. Without the Voice / Text / Data Add-on, you can still roam at pay-per-use prices.  See this post for more details. 
Userlevel 7
Badge +4
Hi Mellisa, make sure you have the $0 international and the $0 long distance addons Also turn on roaming data on your phone in setting if your planning on using data.
Userlevel 4
Hey Melissa,

After adding the specific add-on did you activate it prior to your departure?
Every time I try and call Canada it's saying my phone is restricted yet it's registering on the vodaphone network
Jan Hope wrote:

Hey Melissa,

After adding the specific add-on did you activate it prior to your departure?

Yes at Calgary airport I sent the text and have a reply
Userlevel 7
Badge +4
So do you have the add-ons that David/Paul specifically mentioned to enable in self-serve?
Userlevel 7
Badge +4
Goran wrote:

So do you have the add-ons that David/Paul specifically mentioned to enable in self-serve?

Make sure you give your phone a restart after you've added the free add-ons from David/Paul.
Userlevel 7
Badge +4
Are you dialing the entire 11 digit number?
Userlevel 7
Badge +4
There should be a + before the 11 digit as well, no? +1-AREA CODE-7 digit number?
Userlevel 7
Badge +4
Robert wrote:

There should be a + before the 11 digit as well, no? +1-AREA CODE-7 digit number?

Correct, either "+" or "00", the exit code for the UK.

Reply