Koodo Community

Community

Solved

Easy roam not working after crossing from Ontario into New York although at@t shows up with signal strength


Motorola phone, at@t,

5 replies

Userlevel 6
Badge +4
Hi there...

Try to go into settings, Mobile networks and try to select manually another carrier to see if you pick up services...

But, what is it that you see? Emergency calls only? Are you able to do something with your phone? (text, call, internet)

Userlevel 7
Badge +4
Log into self serve and make sure the free International voice roaming and International data roaming are added to your account
Userlevel 7
Badge +4
Did you activate the "easyroam" option on your account?
Hi there, thanks for getting back. Yes I did activate easy roam and no it never activated although I did get a koodo message saying it was on. Anyway it's past the 24 hour period now and so I don't want to pay. I find contacting koodo hard. Is there a way to get in touch w billing to ensure this is not on my account? Thank you A
Userlevel 7
Badge +4
arnold wrote:

Hi there, thanks for getting back. Yes I did activate easy roam and no it never activated althoug...

It doesnt charge your account if you didnt use it.

Just check your next pdf invoice as regualr practice to make sure all is ok

Reply