Koodo Community
Solved

Easy roam activated but no network


I am now traveling abroad and have activated the EASY ROAM add-on. But there is no network. Can anyone please let me know how to work? Thank you very much.

icon

Best answer by MilkyWay 26 April 2021, 01:55

Can you please let me know where I can add the International Voice Roaming and Data Roaming?  Easy Roam is the only traveling add-on in my add-on list.

To add the International Voice Roaming and International Data Roaming add-ons, you just need to follow these steps. 

  1. Log in to your Self Service account.
  2. Once you are in, click “View rate plan”. 
  3. Scroll down to “Manage add-ons”. 
  4. Add “International Voice Roaming” and “International Data Roaming” to your plan.
View original

This topic has been closed for comments

16 replies

Userlevel 7
Badge +4

Have you tried simply restarting your phone?

As well, what country are you traveling in?

Have you tried simply restarting your phone?

As well, what country are you traveling in?

Yes I did restart my phone, I tried for twice. But there’s no network. I am now in China.

Userlevel 7
Badge +4

Yes I did restart my phone, I tried for twice. But there’s no network. I am now in China.

Do you have the International Voice Roaming add-on? What about International Data Roaming? Check your Self-Serve account and see if it’s there. It may be the reason why you are not connected to a network. You should also turn data roaming on if you plan to use data or picture messaging.

Userlevel 7
Badge +4

Also check if your phone is set to manual network selection or not. If it is, you'll have to manually select the network to connect to.

Have you tried simply restarting your phone?

As well, what country are you traveling in?

Yes I did restart my phone, I tried for twice. But there’s no network. I am now in China.

Do you have the International Voice Roaming add-on? What about International Data Roaming? Check your Self-Serve account and see if it’s there. It may be the reason why you are not connected to a network. You should also turn data roaming on if you plan to use data or picture messaging.

I checked the add-ons in my plan, and the “$13/day Easy Roam INTL” is already here. I don’t know there is any other International Voice Roaming or Data Roaming. Isn’t the Easy Roam add-on the one for travelling oversea phone call, text and data?

Also check if your phone is set to manual network selection or not. If it is, you'll have to manually select the network to connect to.

Thank you for your reminding. It is automatic network selection. But so far no network is selected. I am so concerned to miss any important calls or text messages. 

Userlevel 7
Badge +4

Also, what phone are you using? The cellular frequency bands in China are different from those used in Canada so not all devices will be compatible.

Also, what phone are you using? The cellular frequency bands in China are different from those used in Canada so not all devices will be compatible.

I am using a Huawei P20, made in China. So it shouldn’t have any frequency problem.

Userlevel 7
Badge +4

I am using a Huawei P20, made in China. So it shouldn’t have any frequency problem.

As I mentioned earlier, did you check your Self Serve account to see if you have added International Voice Roaming and International Data Roaming to your line? If you don’t have those add-ons, it wouldn’t work even if you added Easy Roam to your account.

As I mentioned earlier, did you check your Self Serve account to see if you have added International Voice Roaming and International Data Roaming to your line? If you don’t have those add-ons, it wouldn’t work even if you added Easy Roam to your account.

Can you please let me know where I can add the International Voice Roaming and Data Roaming?  Easy Roam is the only traveling add-on in my add-on list.

Userlevel 7
Badge +4

Can you please let me know where I can add the International Voice Roaming and Data Roaming?  Easy Roam is the only traveling add-on in my add-on list.

To add the International Voice Roaming and International Data Roaming add-ons, you just need to follow these steps. 

  1. Log in to your Self Service account.
  2. Once you are in, click “View rate plan”. 
  3. Scroll down to “Manage add-ons”. 
  4. Add “International Voice Roaming” and “International Data Roaming” to your plan.
Userlevel 7
Badge +4

Hi CKJ. You go into self-serve, login, view rate plan, then manage add-ons. From there you will be able to. Restart your phone afterwards. If it won't auto connect, select manual, let the list populate after a minute or two, and try to manually connect.

To add the International Voice Roaming and International Data Roaming add-ons, you just need to follow these steps. 

  1. Log in to your Self Service account.
  2. Once you are in, click “View rate plan”. 
  3. Scroll down to “Manage add-ons”. 
  4. Add “International Voice Roaming” and “International Data Roaming” to your plan.

Thank you for your detailed instruction. But like I said before, in my add-on list, there is no “International Voice Roaming” or “International Data Roaming”. I now have activated $13/day Easy Roam INTL and Pay-Per-Use Intl Long Distance, and here are the rest add-ons I can choose: Call Control, International Long Distance Saver, Data Block with Picture Message, Instant Voicemail, Visual Voicemail, U.S. Unlimited Minutes, China & Hong Kong Unlimited Minutes and India 1000 Minutes. I am not sure it is because I am a new user in Koodo. Is there any customer service number I can call for help? I am feeling so frustrated.

Userlevel 7
Badge +4

To add the International Voice Roaming and International Data Roaming add-ons, you just need to follow these steps. 

  1. Log in to your Self Service account.
  2. Once you are in, click “View rate plan”. 
  3. Scroll down to “Manage add-ons”. 
  4. Add “International Voice Roaming” and “International Data Roaming” to your plan.

Thank you for your detailed instruction. But like I said before, in my add-on list, there is no “International Voice Roaming” or “International Data Roaming”. I now have activated $13/day Easy Roam INTL and Pay-Per-Use Intl Long Distance, and here are the rest add-ons I can choose: Call Control, International Long Distance Saver, Data Block with Picture Message, Instant Voicemail, Visual Voicemail, U.S. Unlimited Minutes, China & Hong Kong Unlimited Minutes and India 1000 Minutes. I am not sure it is because I am a new user in Koodo. Is there any customer service number I can call for help? I am feeling so frustrated.

That's strange. It's supposed to show up there. In the meantime, I flagged a rep to help you out.

Userlevel 5
Badge +4

Hi there! Thanks for reaching out to us. Please restart your phone and manually select from the settings of your phone the network of the local mobile provider with the strongest signal and wait for a few seconds for the phone to connect.  It should work now! :). 

Hi everyone, there was network finally this morning when I woke up. Phone calls and text messages are received. Just don’t know why there was no network in the past 10 days. Anyway thank you guys so much for your help.