Koodo Community
Question

easy roam


Trying to add easy roam while in Europe but it wont let me. There is an error message. how do I speak to a human customer service? I dont have a call back number. this is really frustrating.


22 replies

Userlevel 7
Badge +4

Does it give you any errors when you text ROAM to 7626? That is an alternative way of adding it.

Userlevel 7
Badge +4

Trying to add easy roam while in Europe but it wont let me. There is an error message. how do I speak to a human customer service? I dont have a call back number. this is really frustrating.

I have flagged a Koodo rep to see if they can help you out. 

Userlevel 7
Badge +4

What error are you getting? Can you please try to clear your browser's cache or try another browser 

Userlevel 1

What I’m thinking is this:  whatever you are trying to do is redirecting you to a website to add the service.  But since the data is not setup, the link gives you an error because you don’t have access.

I would try connecting the phone using wifi (eg. at a local restaurant or hotel hotspot) and try again to see if that works.

 

Does it give you any errors when you text ROAM to 7626? That is an alternative way of adding it.

I tried but I don’t have any network so it won’t send the text. 

What I’m thinking is this:  whatever you are trying to do is redirecting you to a website to add the service.  But since the data is not setup, the link gives you an error because you don’t have access.

I would try connecting the phone using wifi (eg. at a local restaurant or hotel hotspot) and try again to see if that works.

 

Yup I tried that too but it still does not work. 

What I’m thinking is this:  whatever you are trying to do is redirecting you to a website to add the service.  But since the data is not setup, the link gives you an error because you don’t have access.

I would try connecting the phone using wifi (eg. at a local restaurant or hotel hotspot) and try again to see if that works.

 

Yup I tried that too but it still does not work. 

 

Userlevel 1

An alternative - if you bring a laptop or tablet with you, or if there is a computer you can access at your hotel business center:

  1. Log into Koodo website with your email/password
  2. At the top, click Self Serve → Mobile Services
  3. At the item Easy Roam, click on “Details”
  4. Click “Add to plan”

 

 

 

Userlevel 1

What I’m thinking is this:  whatever you are trying to do is redirecting you to a website to add the service.  But since the data is not setup, the link gives you an error because you don’t have access.

I would try connecting the phone using wifi (eg. at a local restaurant or hotel hotspot) and try again to see if that works.

 

Yup I tried that too but it still does not work. 

 

 

What kind of plan do you have?  It seems to indicate that you are not allowed for roaming.

 

 

An alternative - if you bring a laptop or tablet with you, or if there is a computer you can access at your hotel business center:

  1. Log into Koodo website with your email/password
  2. At the top, click Self Serve → Mobile Services
  3. At the item Easy Roam, click on “Details”
  4. Click “Add to plan”

 

Yes I tried from tablet and computer and phone 

 

What I’m thinking is this:  whatever you are trying to do is redirecting you to a website to add the service.  But since the data is not setup, the link gives you an error because you don’t have access.

I would try connecting the phone using wifi (eg. at a local restaurant or hotel hotspot) and try again to see if that works.

 

Yup I tried that too but it still does not work. 

 

 

What kind of plan do you have?  It seems to indicate that you are not allowed for roaming.

When I was in the US it did send me the roam option but now it doesn’t . I’m on a monthly plan 

 

 

I’m on a monthly plan 

Userlevel 1

 I’m noticing is your screen showing “...” beside the wifi symbol.  That seems to indicate that you are not establishing any cellular connections whatsoever - not even voice.  Are you at a country that’s supported by Koodo’s roaming service?

I may want to call Koodo’s service in the morning to find out what’s happening.  Or you could pick up a local prepaid sim and use that instead.

 

 

Yeah I usually do the prepaid thing but it’s quite complicated with their terms. I have used easy roam when I was with Fido and because it is just a couple days that I need if I don’t really want to have a SIM card here. And yes Switzerland is on the list. 

I tried calling them but I don’t have a callback number so I’m trying to get help through their Facebook. I really wish I could talk to a human from their team on the phone. 

 

I took automatic off and now it shows the networks but it won’t connect 

Userlevel 1

Currently it’s past midnight in Canada so I don’t think they’ll be answering.  They are also doing maintenance on their website too (which doesn’t help either) until 6am Toronto time.

Koodo’s list has 3 provider listed, which are shown on your phone.  You can try choosing those and see if any of them would manually connect.  Otherwise you just may need to contact Koodo to find out what’s happening with your account.

 

 

Thank you so much for trying to help me :) I really appreciate it :)

Userlevel 7
Badge +4

Hi @cristinam ,

 

The roaming services, Easy Roam international and Easy roam US, are now active on your line, with a device restart, you should be able to see the available networks in your current location.

 

Please let us know if you still encounter issues in hooking up your phone to a foreign network.

 

Thanks! 

Looks like it’s working! Thank you! 

Reply