Koodo Community

Community

Data plan is not working? It says I have it but I cannot connect to Internet using data.


Have the 30 plan for the US but the data won't Work. I have data enabled in my settings but I cannot connect to the Internet without wifi.

12 replies

Userlevel 7
Badge +4
Hello Natalie,

Did you activate data roaming on your phone?
Userlevel 7
Badge +4
Did you also enable data roaming? Try restartinyour phone after you check
Yes roaming is activated.
Restarting did not help.
I don't usually carry a plan in Canada but got the plan for while I am in the states. Could this be an issue? For $75 I better get this to work.
My wifi is spotty. Still hoping for a response
Userlevel 7
Badge +4
Your phone should work for pay-per-use data even without a plan. Do you have a data block on your phone, to,prevent overages in Canada? If so that may be the root of your problem.
David wrote:

Your phone should work for pay-per-use data even without a plan. Do you have a data block on your...

Yes that could be. How do I fix it?
Userlevel 7
Badge +4
David wrote:

Your phone should work for pay-per-use data even without a plan. Do you have a data block on your...

If you have a data block, then you have to contact Koodo to remove it.
Send them a PM through FB and request it.
https://www.facebook.com/Koodo
Hey! I am having the same problem as Natalie. I also enabled roaming. How does one stop the data blocking? What is the procedure?
Userlevel 7
Badge +4
Kim Dillon wrote:

Hey! I am having the same problem as Natalie. I also enabled roaming. How does one stop the data ...

Did you restart your phone?  Did you get a Roaming add-on?
Make sure you have a $0 International Data Roaming add-on activated.
Login to self serve and check it. Also if you have a data block ion your account.

If you have an add-on : Data block w pics, then you might be able to removed it through self serve. But if you get an error message, you need to contact them.
Userlevel 7
Badge +4
On an Android phone, there are a few additional things you can try if US roaming is not working:

In your mobile network settings, change network type to [i]EXCLUDE [b]LTE. Some locations may only be working on the older 3G standard.

In network providers, deselect [b]automatic and let the phone populate with the eligible local networks (may take a few minutes). Then select either AT&T or T-Mobile manually.

Don't forget to revert the setting when you get back to Canada.

Reply