Koodo Community

Cannot enable VoLTE or WiFi Calling on iPhone Xs

  • 30 August 2021
  • 5 replies

I have been unable to enable VoLTE or WiFi Calling after switching to an iPhone Xs from an Android device.

Here are the steps I have tried so far with no luck:

  1. Turn off phone for 5 Minutes
  2. Updating Carrier Settings
  3. Verifying I’m on the latest iOS
  4. Verify Cellular settings. As per https://support.apple.com/en-us/HT203124 I only see the Options shown under “If your carrier doesn't support VoLTE”
  5. Reset Network Settings
  6. Verify APN settings to be “sp.koodo.com”
  7. Enrolling through https://ent.telus.com/acmegw-android/koodo/entitlement/e911:
    It shows me the address I initially opened the account under, I’ve moved 3 times since
    I cannot update the address or get past this step without changing the address.
    Looking at the browser calls in the Developer Console I can see the backend throws an Error 500 with a Java Null Pointer Exception:


  8. Speak to a rep on a callback. He was unable to help me after 30 minutes of trying.

Anything else I can try? The device I am using is a Canadian iPhone Xs I bought from Bell. It is unlocked and my Koodo SIM works fine for LTE data and regular calling.

This topic has been closed for comments

5 replies

Userlevel 7
Badge +4

Could you check if you had the “volte access" add-on in your selfserve? 

Thanks for your reply. I do have the “Koodo VoLTE Access” addon on my plan.

Userlevel 7
Badge +4

Thanks for your reply. I do have the “Koodo VoLTE Access” addon on my plan.

I assumed you tried to reset network settings of the iPhone. 

When you mentioned you cannot enable wifi calling? Did you see the wifi calling toggle in settings? Koodo wifi calling prioritize cellular signal over wifi. So make sure you are in a bad signal reception area or you turn on the airplane mode. 

Also, who was your wifi ISP? Koodo wifi calling had some issue with certain ISP. 

I do see the WiFi Calling toggle, but when I go to enable it i receive an error message: “To allow Wi-Fi calling on this account, contact Koodo.”

Given that I can’t even enable VoLTE I assume something is provisioned incorrectly on my account and my phone isn’t registering with IMS to enable IP based features such as VoLTE and WiFI Calling.

My ISP is Bell and I’m using their Fibe FTTH service. I verified that it is not a DNS Server issue. I use Cloudflare’s but when I switch to Google’s I get the same error.

Thanks again for your time.

Userlevel 7
Badge +4

I think the problem could be the e911 that you mentioned earlier. I would try to do it again with whatever address you registered with Koodo. Then later you could change it within your iPhone.