Koodo Community

Community

Solved

Call Display is included in my plan but it never works


My plan states that Outbound Call Display is included but I've never had that actually happen when I call from my phone. It always states the caller as 'Unknown' when i'm making or receiving calls. How can I enable call display?

30 replies

Userlevel 7
Badge +4
Depending on your phone, go to your settings for your phone app and make sure Show My Caller ID is on
Thanks for the reply, I'm using an iPhone 4S, it used to have caller display when I first got the koodo plan a few years ago but after a while I decided I didn't need it (it was a paid service at the time) so I removed it. Now I want it back on, I login to my plan details on koodo and it states that it's included in my plan. I don't see any software settings in the iPhone to turn it on.
Userlevel 7
Badge +4
Mat Nightingale wrote:

Thanks for the reply, I'm using an iPhone 4S, it used to have caller display when I first got the...

Ok so you are talking about incoming call display. Unfortunately that add-on is no long available as all current plans include free call display. If you want to get call display back, you will have to switch to a current plan.
Mat Nightingale wrote:

Thanks for the reply, I'm using an iPhone 4S, it used to have caller display when I first got the...

When I go to in Self-Serve, under Plans and Add-ons > Add-ons, it lists the Included Services and one of them listed is Call Display Outbound, but still my caller ID doesn't show up on the other end when I make a call.
Userlevel 7
Badge +4
Mat Nightingale wrote:

Thanks for the reply, I'm using an iPhone 4S, it used to have caller display when I first got the...

Does the other party you are calling have Caller ID?
Mat Nightingale wrote:

Thanks for the reply, I'm using an iPhone 4S, it used to have caller display when I first got the...

Yes, it's my wife. We're both on the same plan (same account even) with same phones.
Userlevel 7
Badge +4
Mat Nightingale wrote:

Thanks for the reply, I'm using an iPhone 4S, it used to have caller display when I first got the...

But since you have the same plan, did you both remove the Call Display Add-on? If so, it doesnt matter if your phone is Showing your Caller ID if she doesnt have the Add-on to receive it
Mat Nightingale wrote:

Thanks for the reply, I'm using an iPhone 4S, it used to have caller display when I first got the...

It was removed from both plans, but when I login to both phone numbers they both list Call Display Outbound as included in the plan, both phones had caller ID turned on in the software, and neither account has Call Display Restrict on.
Userlevel 7
Badge +4
Mat Nightingale wrote:

Thanks for the reply, I'm using an iPhone 4S, it used to have caller display when I first got the...

OUTBOUND, as in it will display your number on outbound calls. Unless you have INBOUND call display, callers' numbers will not be displayed on your phone.
Userlevel 7
Badge +4
Mat Nightingale wrote:

Thanks for the reply, I'm using an iPhone 4S, it used to have caller display when I first got the...

Ok this makes sense now. A phone needs the Call Display Add-on in order to show caller ID. If you call another phone with call display it will show your caller ID
Mat Nightingale wrote:

Thanks for the reply, I'm using an iPhone 4S, it used to have caller display when I first got the...

If I call a friend (with caller ID) who has removed me from their contacts then my phone comes up as Unknown.
Userlevel 7
Badge +4
Mat Nightingale wrote:

Thanks for the reply, I'm using an iPhone 4S, it used to have caller display when I first got the...

Koodo only offers NUMBER display, not name display. If they don't have you in their contacts, only your number will be shown.
Mat Nightingale wrote:

Thanks for the reply, I'm using an iPhone 4S, it used to have caller display when I first got the...

I don't get a number, just Unknown. It makes no difference (I've tried it just now) whether the person calling me is in my contacts or not, incoming and outgoing calls display as Unknown
Userlevel 7
Badge +4
Mat Nightingale wrote:

Thanks for the reply, I'm using an iPhone 4S, it used to have caller display when I first got the...

YOU said you don't have incoming call display. THAT's why you don't see a number on incoming calls.
Mat Nightingale wrote:

Thanks for the reply, I'm using an iPhone 4S, it used to have caller display when I first got the...

So how do I get it back, I don't see any option to add that as an add-on? Isn't the whole point of Koodo that you can change you plan as you go along and add/remove things? Don't tell me I need to "upgrade" to a new plan just to get features that were previously offered in my existing plan. If that's the case it seems like Koodo are just forcing users into newer more expensive plans, may be it's time to move my plan elsewhere.
Userlevel 7
Badge +4
Mat Nightingale wrote:

Thanks for the reply, I'm using an iPhone 4S, it used to have caller display when I first got the...

Unfortunately, call display is no longer available as a separate add on, as ithas been included in every base plan koodo has offered for almost 2 years now. The only way to get call display now would be to switch to one of the current plans.
Mat Nightingale wrote:

Thanks for the reply, I'm using an iPhone 4S, it used to have caller display when I first got the...

This is a joke. I suppose I'd better start looking at alternative providers.
Userlevel 4
Mat Nightingale wrote:

Thanks for the reply, I'm using an iPhone 4S, it used to have caller display when I first got the...

Over call display? Really? Take a look at your plan and the ones that are currently available. Chances are, it may end up being a better option to just change the plan.
Userlevel 7
Badge +4
Mat Nightingale wrote:

Thanks for the reply, I'm using an iPhone 4S, it used to have caller display when I first got the...

What plan do you have? I used to had a $15 plan with no call display, no voice mail, no call waiting. I had 50 minutes airtime- no free evening, no free week end included. You might pay extra but you will get a lot more specially Koodo offers promo plan now.
Userlevel 1
Mat Nightingale wrote:

Thanks for the reply, I'm using an iPhone 4S, it used to have caller display when I first got the...

Tough to find any deals better than Koodo. Their competition all price match with one another and their parent companies are far worse. Depending on how you use your phone, and how often you use it, there may be some other things you can do. If you only use your phone for local or provincial calls, Chatr would be a good alternative for unlimited calling from $20/month and $25/month, respectively (50 outgoing texts per month on both). They have a Canada-wide $35/month that includes unlimited text. It's on the Rogers network so coverage is solid. They include call display (but voicemail has a 25 cent per minute retrieval charge, except on the $35 plan, in which it is included). Note, to make the calls, you have to be in a Chatr zone, but their zones are pretty large in main centre's like Toronto, Montreal etc (I don't know where you are). There are also the new entrants (of which I would recommend Wind over Mobilicity and Public Mobile), good prices but receptions in some areas might be an issue.
Userlevel 7
Badge +4
Mat Nightingale wrote:

Thanks for the reply, I'm using an iPhone 4S, it used to have caller display when I first got the...

Depending on how much you use your phone and what features you need, prepaid might even be an option. I find the old $15/$20 plans and prepaid are very similar, in fact prepaid offers more than the $15 monthly plan. You would lose however your unlimited calling between family members on the same account... but it is an option to consider if you are a light user. You could certainly shop around for other providers, but as others said already you might be hard pressed to find a better deal than Koodo 🙂
Userlevel 7
Badge +4
Outbound call is only to show your number on outbound calls. The setting to enable and disable this on an iphone is under settings->(phone/call)
Timo Tuokkola wrote:

Outbound call is only to show your number on outbound calls. The setting to enable and disable t...

This is enabled on the phone, but still my caller ID doesn't show up on the other end when I make a call.
Userlevel 2
Timo Tuokkola wrote:

Outbound call is only to show your number on outbound calls. The setting to enable and disable t...

Does the person you are calling have caller id on their plan? Does your telephone number appear on their phone?
Timo Tuokkola wrote:

Outbound call is only to show your number on outbound calls. The setting to enable and disable t...

Yes, it's my wife she. We're both on the same plan (same account even) with same phones. The receiving phone just says 'Unknown' when I call.

Reply