Koodo Community
Solved

Why has my signal quality gotten worse?

  • 17 November 2020
  • 5 replies
  • 762 views

Hello, 

I've been with Koodo for more then 2 years now and I've had no issues, everything was perfect. I can't pinpoint when exactly this issue started happening but I think around August or September 2020 is when I started noticing. Everytime I receive phone calls at work, the first 30 seconds to 1 minute of speaking is inaudible to the caller everytime I speak. I could hear them clearly but they can barely understand half of what I say as they mentioned my voice cuts off frequently. My lifestyle has not changed, my job hasn't changed, I even went outside and they still couldn't hear me clearly, I'm still using the same phone for 1 year (Note 9). I really don't know why this is happening now when my service was perfect before. Anyone have any ideas? This is extremely frustrating...im thinking it may be my phone but I really have no idea 

icon

Best answer by rikkster 24 December 2020, 11:16

Resetting your phones’ network settings often fixes network connectivity problems. On Android, this setting is usually found under the Backup & Reset area of the phone. On iPhone, go to Settings > General > Reset > Reset Network Settings. (@Goran’s answer).

The technician likely turned off automatic network selection. This is particularly useful for customers who reside in areas near the U.S. border as this setting prevents the phone from inadvertently connecting to a U.S. network. 

To turn automatic network mode off on Android, go to Settings > Network & Internet > Mobile or Cellular Networks > Network or Network Operators - slide the switch to disable automatic network selection. Or do a manual search for Koodo. (Menus vary slightly with different Android devices).

On iPhone, go to Settings > Cellular > Network Selection - slide the switch to the off position, then choose Koodo.

This post is a month old so you may not get a response from the author, likely because the issue was resolved and there were no further replies. Since you’re experiencing an issue with your phone, it’s best to create a new post.

View original

This topic has been closed for comments

5 replies

Userlevel 7
Badge +4

Is there anyone else with Koodo or Telus with the same problems around you? You can try swapping your Sim card with another Sim card to see if the problem follows. Maybe resetting network settings or just the Sim card reinsert ion would also help.

Unfortunately none of my colleagues have Koodo or Telus so there is no way to test it out. My wife however, is with Public Mobile (which also uses Telus towers I believe) plus we work together in the same building but this issue doesn't happen to her at all and she uses iPhone 7 plus. I will try to reinsert the Sim and see if it happens again tomorrow. I live in Woodbridge, ON by the way so the reception here shouldn't be bad. 

Userlevel 7
Badge +4

Unfortunately none of my colleagues have Koodo or Telus so there is no way to test it out. My wife however, is with Public Mobile (which also uses Telus towers I believe) plus we work together in the same building but this issue doesn't happen to her at all and she uses iPhone 7 plus. I will try to reinsert the Sim and see if it happens again tomorrow. I live in Woodbridge, ON by the way so the reception here shouldn't be bad. 

Try your sim in her phone and her sim in your phone.  Does the problem stay with your sim or your phone?

Userlevel 3

I have the same problem and mine also began in August. I thought it was the concrete in the building was blocking the signal and I needed a clear line of sight to a tower. But on the 20th floor? Then I began to get an echo after about 15 minutes. That still happens but it takes 30 minutes now. The first issue was fixed by a technician at Bayshore in Ottawa she turned off a setting in networks. (One of the experts may clarify, she said it causes the phone to juggle between local and long distance). The setting disrupts the phones’s ability to focus on one tower. I’m sorry for not being more clearer, but this may help the technician try a test for you. 

Do you have your “Data Roaming” turned on? If you don’t require it in Woodbridge (you shouldn’t as you are in Canada), try turning that off. Some phones have problems deciding whether to connect via roaming or without it.

Badge +4

Resetting your phones’ network settings often fixes network connectivity problems. On Android, this setting is usually found under the Backup & Reset area of the phone. On iPhone, go to Settings > General > Reset > Reset Network Settings. (@Goran’s answer).

The technician likely turned off automatic network selection. This is particularly useful for customers who reside in areas near the U.S. border as this setting prevents the phone from inadvertently connecting to a U.S. network. 

To turn automatic network mode off on Android, go to Settings > Network & Internet > Mobile or Cellular Networks > Network or Network Operators - slide the switch to disable automatic network selection. Or do a manual search for Koodo. (Menus vary slightly with different Android devices).

On iPhone, go to Settings > Cellular > Network Selection - slide the switch to the off position, then choose Koodo.

This post is a month old so you may not get a response from the author, likely because the issue was resolved and there were no further replies. Since you’re experiencing an issue with your phone, it’s best to create a new post.