Koodo Community
Question

Using up data when I could be using wifi


When I call on my phone or have a call coming in, I can’t use it on wifi. If I am on wifi then I break in and out. I have to turn off my wifi and use my data which means I am using up my data when I shouldn’t have to. I have an iphone 6s plus. My husband has a Samsung and with a different cell service and it doesn’t happen to him, is it my phone or my cell service? I have tried sitting right beside my router, sitting outside, also when using wifi my video chats are pixelated to the other person, always saying a connection problem yet I see them perfect.


10 replies

Userlevel 7
Badge +4

You could try resetting network settings. There'd be nothing on Koodo’s side to impact your data use on WiFi. Is your iPhone the only thing that is impacted by one way quality?

Userlevel 7
Badge +4

How did you know the phone could not use WiFi when you called or someone called you? Which test/app did you try?

The 6s plus could use VoLTE if you are a postpaid customer. Can you go and check Settings » Cellular » Cellular data option » Voice & Data » LTE, VoLTE ON?

If you use VoLTE, the phone theoretically wouldn’t drop to 3G (when somone calls or you call someone) and hence avoid any cellular data connection disruption (that might cause disconnection to any app if you were using cellular LTE data at the time).

First, my phone is the only one in the house that is impacted by this. My husband has a samsung on a  different cell provider and has no problems suing wifi for calls

Second, I knew I can’t use wifi for calls since everytime someone calls or I call them, they tell me I am breaking up, I hang up, turn off wifi, and call back than there is no problem

Third, how do I reset network setting on this iphone 6s plus?

Fourth, I don’t have VoLTE but my phone while on cellular is always saying LTE. I don’t think I ever have full bars, even the other day, I was in the city and had 2 bars if I stuck the phone out the window.

Userlevel 7
Badge +4

First, my phone is the only one in the house that is impacted by this. My husband has a samsung on a  different cell provider and has no problems suing wifi for calls

Second, I knew I can’t use wifi for calls since everytime someone calls or I call them, they tell me I am breaking up, I hang up, turn off wifi, and call back than there is no problem

Third, how do I reset network setting on this iphone 6s plus?

Fourth, I don’t have VoLTE but my phone while on cellular is always saying LTE. I don’t think I ever have full bars, even the other day, I was in the city and had 2 bars if I stuck the phone out the window.


1st, You need apple compared to apple. Different phones on different providers can behave significantly different. Can you put your SIM into the Samsung phone and test?

2nd, Can you elaborate more? this was strange. Are you using normal cellular service for calling or you were using Viber, facetime audio? or any 3rd party app. Turning on/off wifi should not have any affect on your cellular calling

3rd. Go to settings » General >> Reset » Reset network settings.

4th. VoLTE is not the same as LTE on top of the phone screen. As I mentioned in the previous post: “ Can you go and check Settings » Cellular » Cellular data option » Voice & Data » LTE, VoLTE ON? . Is the VoLTE on?

1st. I understand different phones work differently, just meant that my husband has no problem using wifi on the phone. I did reset network and will retry a call, and will try it in my husbands phone..

2nd. This problem I have when I am home and have wifi to use. I am using my koodo cellular service. If I have wifi turned on (so using wifi instead of my cell data) and a call comes in on the phone, if I answer without turning off my wifi the person I am calling tells me I am breaking up so I tell them I will call right back, I hang up, go to settings, turn off wifi, then call back (so now I am using my cell data) and I am no longer breaking up to the other person.  Same goes if I call out. And when I turn off wifi the other person actually comes in a lot clearer also. I tried it on a few calls to see if there was a difference where I was calling, and no difference (called NS and SK along with QC)

3rd I see what the LTE is beside the cellular bars and Koodo but I always only have 1 maybe 2 bars of reception most times. I only use WhatsApp, WeChat and Messenger for video calls, most time they are blurry but I always am using wifi during that time.

It is either my iphone, which I have had several problems with (i have taken it to Apple service center) or it is the celluar service. It is just very frustrating to have to always call someone back or make sure wifi is turned off before I answer the phone. I shouldn’t have to do this.

Oh and after resetting the network, it made no difference that way.

Userlevel 7
Badge +4

If you are using WhatsApp, WeChat or Messenger (FaceTime) for video calls on Wi-Fi, that has nothing to do with your Koodo cellular connection. That they work fine on cellular data, but not on Wi-Fi, suggests an issue with your phone/Wi-Fi. What happens if you switch to Airplane mode, turn on your Wi-Fi, and then make the call? This would completely remove the cellular section of the phone from the test?

 

Userlevel 7
Badge +4

1st. I understand different phones work differently, just meant that my husband has no problem using wifi on the phone. I did reset network and will retry a call, and will try it in my husbands phone..

2nd. This problem I have when I am home and have wifi to use. I am using my koodo cellular service. If I have wifi turned on (so using wifi instead of my cell data) and a call comes in on the phone, if I answer without turning off my wifi the person I am calling tells me I am breaking up so I tell them I will call right back, I hang up, go to settings, turn off wifi, then call back (so now I am using my cell data) and I am no longer breaking up to the other person.  Same goes if I call out. And when I turn off wifi the other person actually comes in a lot clearer also. I tried it on a few calls to see if there was a difference where I was calling, and no difference (called NS and SK along with QC)

3rd I see what the LTE is beside the cellular bars and Koodo but I always only have 1 maybe 2 bars of reception most times. I only use WhatsApp, WeChat and Messenger for video calls, most time they are blurry but I always am using wifi during that time.

It is either my iphone, which I have had several problems with (i have taken it to Apple service center) or it is the celluar service. It is just very frustrating to have to always call someone back or make sure wifi is turned off before I answer the phone. I shouldn’t have to do this.

As David mentioned, If you are using 3rd party app like Whatsapp, wechat and messenger, and the call quality wasn’t good if you are on WIFI then it has nothing with Koodo. It is your WiFi connection signal issue. You might want to check your WiFi connection.

If you turned off WIFI and you could use 3rd party apps (Whatsapp, wechat and messenger) without any interference then Koodo cellular was actually better than your WiFi in the house.

Thank you David I will try it with airplane mode and than wifi.  Oh and non of my video calls on anything are any good most times. I wish I could get them clear like in the commercials!! lol

Userlevel 7
Badge +4

You can also try speed test to see what the down and upload speeds as well as ping are for your phone on WiFi.

Reply