Koodo Community

Using easy roam in Costa Rica and calls/text work but no data

  • 27 September 2020
  • 6 replies
  • 83 views

I am in Costa Rica and using easy roam. My texting and calling works but I have no data. It says there is no internet connection. I have restarted my phone a couple times, hoping that would help but it didn't. 


6 replies

Userlevel 7

Calls and text use  different protocols then data intensive applications. It is possible that your internet setup may not be compatible with the local mobile provider you are currently using. Resetting your internet setting may be the first step.  If it does not work, please consider going to a local mobile store and have them look at your internet setting (and suggest changes?). Before changing anything, write down the current setting and restore them upon return to Canada. I hope that other koodo experts (moderators) will provide their input based on their experience or refer you to relevant links. Good luck!

Userlevel 7
Badge +4

Have you enabled roaming data in the phone's settings?

Userlevel 7
Badge +4

@AylaP Local network signals could also be just too weak to provide  strong enough connection for data. You could  try manually changing the network provider. Go to settings on your phone.  Look for ‘cellular’ then ‘network selection’ or something like that. It should list the local providers’ names. Switch to another see if that helps.

That makes sense. I have tried the 3 providers and none worked but I was thinking it may be something about the signal not being strong enough. I noticed it worked when I was in the capital city getting in the taxi and then not since I got to a more rural area.  My roaming data is enabled. 

Thank you 

Userlevel 7
Badge +4

Just 1 more thing to check.

Go into self serve and view rate plan and see if the free “International Data Roaming” is in your rate plan.  This is needed to roam with data

Userlevel 7

Make sure that you enable ‘Automatically select network’ under Network settings. If you use the cell in the city (strong signals) and in rural areas (low signals), you may need to let your cell automatically select the optimal network.

Reply