Koodo Community

Community

Solved

using data when there is wifi


My phone is a samsung galaxy s3. I have a data plan but use my home wifi when available. Almost every month at some point my phone will switch from my home wifi to my data plan without my knowing and it eats up my data. I looked through the usage and you can see the random spike in usage as well as it seems that everytime it happens its youtube. I have been on youtube before and it uses wifi but once a month it will use the data instead. I have no idea how to fix it from doing this and am getting frustrsted that I get a week of data before it gets used up for no reason. For the next 3 weeks I have no data now. I wont waste my time trying to get it refunded but I just want it to stop happening. Icant afford to spend money on a data plan that I never get to use.

10 replies

Userlevel 7
Badge +4
Settings>Wi-Fi>Advanced>Keep Wi-Fi on during sleep. But this is for when wifi turns off when your phone is asleep. While watching youtube, I would make sure you have a strong wifi signal so your connection does not drop. Does this only happen at home? If so, it could be your wifi signal or modem that is acting up causing you to lose wifi connection
At home is the only time i use wifi so i cant say if its the signal or modem but I can say that we have 2 samsung galaxy s3's and only one does this. The other one never uses data when it is supposed to be on wifi.
Userlevel 7
Badge +4
Then it could be the wifi thats the isue on your phone. Make sure your phone's OS is up to date and try testing it out along with your other phone at another place with wifi like McDonalds, Starbucks, Tim's, etc
Ok thank you I will look and see if it is up to date. I can try to check it out somewhere else but it only does it randomly about once a month (using the remaining data up). Not too bad when its about to reset but majorly frustrating when i have 3 weeks until reset day 😞.
Badge +4
Hi Paige, It's best to get into the habit of turning mobile data off when not in use. Youtube may be set to periodically update in the background. If your device loses the connection to Wi-Fi, your phone will automatically revert to using mobile data (packet data) if left turned on. To turn off mobile/packet data, navigate to and tap Settings > More settings > Mobile networks - if the 'Use packet data' box is checked, uncheck it. Keep in mind that if you want to send picture messages (MMS), data will need to be turned back on. Also, open the Play Store app on your S3, tap the Playstore logo in the upper left of your screen and then tap Settings. Under General, tap Auto-update apps and select Auto-update apps over Wi-Fi only. Install a data toggle widget on your home screen. The widget takes up very little space on your home screen and provides instant verification as to whether data is on (green) or off (black). It also saves time from having to go through pages of settings to turn mobile/packet data on and off. Data Toggle Widget https://play.google.com/store/apps/details?id=com.farproc.data.enabler
If it is a wifi issue on the phone and update doesnt fix (if there is one) what do i do then?
Userlevel 7
Badge +4
Yea I hate when it's random since it becomes that much harder to diagnose. You may want to take it in for warranty http://help.koodomobile.com/getting-started-with-koodo/before-you-purchase/what-is-your-warranty-and-repair-policy Or if you are in Vancouver or Edmonton you can talk to the Samsumg Store, they maybe be able to provide additional assistance. But I would call ahead first.
Turning off the data when at home isnt an option since i do use it for picture messaging and really shouldnt have to turn it on and off multiple times a day. My problem is that it shouldnt be losing the wifi while home because the second identical phone has no issue keeping it.
Thank you Dennis. I am in NB but will call koodo and look into warranty. You have been helpful while i waited for them to open 🙂
Userlevel 7
Badge +4
Paige Roberts wrote:

Thank you Dennis. I am in NB but will call koodo and look into warranty. You have been helpful wh...

No problem. I know how it feels when stuff doesnt work the way they are suppose to

Reply