Koodo Community
Question

Unable to receive Texts while overseas (India)

  • 27 September 2021
  • 3 replies
  • 30 views

Hello,

 

I’m unable to receive any SMS on my Koodo mobile. I was told that we don’t need to enable any roaming to receive OTPs on mobile.

I did reboot my phone, removed & fixed SIM again. 

Also, explored about enabling Koodo’s EasyRoam feature to receive SMS but they are charging $13/day which doesn’t make sense just to receive SMS. Also, some people telling on other forums that it still doesn’t work after EasyRoam. 

Please suggest what should I do.


3 replies

Userlevel 7
Badge +4

You need to enable international voice roaming in your self-serve. Easy Roam should automatically enable that as well as an option. Receiving SMS is free no matter where you are, but you still need roaming enabled in self-serve to be able to actually roam and receive SMS. Just don’t send any SMS or make or receive any calls or use data, and you won’t pay.

Thanks Goran.

But it has been mentioned on Self Serve $13 per day as charges for Easy Roam.

Does it mean Koodo will charge you $13 per day no matter whether you use any roaming service (send SMS, make/receive calls) or Not ? OR this $13 will be charged only for the days on which you do send SMS or make/receive calls?

I’m particularly concerned for this part. Please guide on this.

Userlevel 7
Badge +4

Thanks Goran.

But it has been mentioned on Self Serve $13 per day as charges for Easy Roam.

Does it mean Koodo will charge you $13 per day no matter whether you use any roaming service (send SMS, make/receive calls) or Not ? OR this $13 will be charged only for the days on which you do send SMS or make/receive calls?

I’m particularly concerned for this part. Please guide on this.

That is not correct.

Easy roam is only charged once you use data, use minutes or send a text. If you don't do any of that, easy roam charges won't get trigger. Same as if easy roam is not enabled. The difference if you accidentily use data or talk you pay the pay per use rate instead of $13. 

Reply