Koodo Community
Solved

Text messages only work on wifi

  • 22 August 2020
  • 7 replies
  • 523 views

Hello,

Yesterday my text messages stopped working on my Koodo phone when away from my home wifi.  I've confirmed my mobile data is on and I can send and receive phone calls.  Are there any suggestions why this would occur?

 

I can see a little Koodo name in the top left corner so I don't think my sim has been swapped.  

 

Any assistance this forum can provide me would be greatly appreciated.

 

Thank you.  

icon

Best answer by Dennis 22 August 2020, 03:31

Traditional texts (SMS, MMS) can only work on the cellular network and will not work on Wifi.

If they are working on wifi it means it is connection to a data based messaging service like imessage, whatsapp, facebook messenger.

 

What phone do you have and what app are you using to send messages?

 

If imessage, try this

https://community.koodomobile.com/android-81490/texts-not-sent-when-wifi-not-available-7799335

View original

7 replies

Userlevel 7
Badge +4

What kind of phone are you using?

Userlevel 7
Badge +4

Traditional texts (SMS, MMS) can only work on the cellular network and will not work on Wifi.

If they are working on wifi it means it is connection to a data based messaging service like imessage, whatsapp, facebook messenger.

 

What phone do you have and what app are you using to send messages?

 

If imessage, try this

https://community.koodomobile.com/android-81490/texts-not-sent-when-wifi-not-available-7799335

Hello Allan and Dennis,

 

I'm using a Huawei P20 EML-L09.  The Messages app is what I'm using.  I think it's the default messages from Android that came with my phone.

 

Thank you.  

Userlevel 7
Badge +4

Hello Allan and Dennis,

 

I'm using a Huawei P20 EML-L09.  The Messages app is what I'm using.  I think it's the default messages from Android that came with my phone.

 

Thank you.  

Look in your messages app setting and make sure it is set to send SMS and any “chat” feature is turned off

Userlevel 7
Badge +4

Also have you tried a simple reboot of your phone and taking out and reinserting your sim card?

Hello Allan and Dennis,

 

Yes I've rebooted my phone and I've removed and rebooted and reinserted my sim card.  

 

I could not find an option in my settings to change to SMS.

 

I then tested sending a text message (with wifi off) and the text failed.  The message had a small message to resend.  I pressed this and had the option to send via SMS.  I selected this and the message was sent.  

 

Looks like my problem is solved.  Thank you all for your assistance.

 

Thank you.  

Userlevel 7
Badge +4

Hello Allan and Dennis,

 

Yes I've rebooted my phone and I've removed and rebooted and reinserted my sim card.  

 

I could not find an option in my settings to change to SMS.

 

I then tested sending a text message (with wifi off) and the text failed.  The message had a small message to resend.  I pressed this and had the option to send via SMS.  I selected this and the message was sent.  

 

Looks like my problem is solved.  Thank you all for your assistance.

 

Thank you.  

Your messaging app is definitely not sending as sms on the first try. 

 

I highly recommend digging deeper into the messaging app settings 

Reply