Koodo Community

Community

Solved

roaming mode problems


My phone randomly switched to being in a 'roaming' mode... although I have not left my city let alone my country. Anyone know how to fix this? it's been almost a week, and I'd rather not be charged for it..

5 replies

Userlevel 7
Badge +4
IF you are roaming on a Canadian network, no problems, as this is one of the requirements the CRTC imposed: cross-carrier roaming. There will be no additional fees to you. If you are roaming on US networks, you can set your phone to connect only to Koodo. Let us know your phone model, and we can help you with the settings.
Userlevel 7
Badge +4
Or are you in the Extended service area? http://help.koodomobile.com/coverage-long-distance-and-travelling/coverage-maps
I'm in 4G LTE coverage. In Hamilton. so I guess I just have to accept that I have a roaming symbol on my phone? and it also says I'm on the Telus network (which I know Koodo is owned by it.. but it also only started last Wednesday).
Userlevel 7
Michelle Gauthier wrote:

I'm in 4G LTE coverage. In Hamilton. so I guess I just have to accept that I have a roaming symbo...

You're fine. I've also seen Telus show up on my phone while I was in Hamilton (QEW & Burlington). It's no biggie. And no you won't be charged. What phone do you have?
Michelle Gauthier wrote:

I'm in 4G LTE coverage. In Hamilton. so I guess I just have to accept that I have a roaming symbo...

LG GB-255G it's an old one. haha

Reply