Feedback
oneplus android 11 mms apn settings | Koodo Community
Koodo Community

oneplus android 11 mms apn settings


Just upgraded in the beta the settings in the help here are wrong. The below works. I deleted both APN's that were there by default and built this one in.

 

 


23 replies

Userlevel 7
Badge +4

What makes you think they're wrong?

The APN settings here: https://www.koodomobile.com/en/help/setting-data-your-non-koodo-phone are the ones that I use successfully on my phone.

What makes you think they're wrong?

The APN settings here: https://www.koodomobile.com/en/help/setting-data-your-non-koodo-phone are the ones that I use successfully on my phone.

Honestly I went through those ones meticulously and it worked for text/phone but i could not get MMS or web. 

 

Might be versioning of the phone. I have a OP 6T so it's older. And Android 11 is in beta for us 

Userlevel 7
Badge +4

I tested Koodo APN on my LG G7, the MMSC was set the same as the OP (which is different from Koodo link).

I guess Koodo recently updated their own APN but they haven’t updated the website.

Hi, I have a one plus 6T and I lost mobile data since I’ve done the android 11 update. 

I already try to apply your APN settings but it still not work. 

Do you know if there is anything else to do ? 

 

I already tried different reboot (with airplane, with data or without, with wifi or without, with sim card or without, changing sim slot, reset settings ...) 

Userlevel 7
Badge +4

Hi, I have a one plus 6T and I lost mobile data since I’ve done the android 11 update. 

I already try to apply your APN settings but it still not work. 

Do you know if there is anything else to do ? 

 

I already tried different reboot (with airplane, with data or without, with wifi or without, with sim card or without, changing sim slot, reset settings ...) 

Could you take a snapshot of your current apn settings here? We might know if there is something wrong with it. 

 

 

 

 

I juste see that Type APN is not what I type “default,supl,mms” … I tried to change it but I can’t save it :/ 

Userlevel 7
Badge +4

 

 

I juste see that Type APN is not what I type “default,supl,mms” … I tried to change it but I can’t save it :/ 

Can you create another APN and put in the parameters? after that set that one to default

Userlevel 7
Badge +4

 

 


Can you leave the “proxy” and “port” parameters empty? From the Koodo link, you don’t have to set those 2 parameters.

I could change to these values but it doesn't work

 

Oh it works except for mms 😔 i really can't change apn type to 'default,supl,mms'

Userlevel 7
Badge +4

Deleted. double post

Userlevel 7
Badge +4

You didn't set up the "mms proxy” as per Koodo link. I suggest you check the apn with thiS

 

I’ve setup mms proxy and mms port and mms still doesn’t work 

Userlevel 7
Badge +4

I’ve setup mms proxy and mms port and mms still doesn’t work 


Can you show a snapshot of your current settings ?

 

Userlevel 7
Badge +4

From the screenshot, the apn type wasn't the same as as the value in my screenshot. 

The APN type should be default,mms,supl

The apn protocol should be IPv4

MNVO should be None

MNVO value “not set"

I would suggest you try it and restart the phone afterwards. Hopefully it helps

 

 

It still doesn't work. 

But i can't change APN Type. Maybe the problem Come from this setting but i've tried but nothing works to change it 😕

Userlevel 7
Badge +4

It still doesn't work. 

But i can't change APN Type. Maybe the problem Come from this setting but i've tried but nothing works to change it 😕


Then I would suggest you remove the beta software version or ask at the Oneplus forum. it might be one of the earlier issue that wasn’t been fixed.

It's not the beta version 😔 

Yes i will contact oneplus again to resolve the problème of the APN type. 

Thanks a lot for your help. The situation is better. I've recovery mobile data at least 😊

I solved my problem ! So, if someone has the same one with Android 11 and a oneplus 6T :

 To be able to saved an other APN TYPE setting : open the configuration of the APN. Remove the sim card. Change the setting. Save the configuration. And replace the sim card. 

The parameter is saved and MMS will work again 🥳

Badge +4

The solution from the OnePlus community was to select IMSI as the MVNO type. This would allow the APN configuration to be edited/saved. Worked for the OnePlus 6, it might work for the OnePlus 6T. 

https://forums.oneplus.com/threads/help-cant-add-apn-settings.981063/  - see post #7

I solved my problem ! So, if someone has the same one with Android 11 and a oneplus 6T :

 To be able to saved an other APN TYPE setting : open the configuration of the APN. Remove the sim card. Change the setting. Save the configuration. And replace the sim card. 

The parameter is saved and MMS will work again 🥳

 

I have a oneplus 6 and was experiencing the same issues. Opening the settings then removing the sim card WORKED and let me save the APN type to “Default,supl,mms” (instead of it always reverting to “xcap”). All other settings were the same as the original post and it immediately fixed my problem, without a restart.

 

THANK YOU

Reply