Koodo Community

old phone in restart loop after ported to koodo

  • 11 October 2015
  • 2 replies

Earlier today I joined Koodo with porting my number from Rogers (thank you
to my cousin for sending the invite 🙂 That part appears to have worked flawlessly as my account/plan here is fully active and shows my old phone number and plan. The cell even accepted the unlock code that rogers provided to unlock the phone, (which the koodo kiosk sales rep entered for me) ... but after that is where things began to fail as the phone has been stuck in a restart loop since then :(
*#7465625# shows that the 3g Samsung a746 phone is completely unlocked, and the phone sees that the rogers sim is deactivated when re-inserting it. But, the phone will continuously restart itself in a loop only when the koodo sim is inserted. The phone will start up, load the icons on the screen, say that it's searching, and then restart. The only way to stop this cycle is to reinsert the deactivated rogers sim, put the phone in airplane mode, and then swap the sim back to koodo (at least I can still use my alarm clock lol).
After a little research on the issue, It appears that some people who experienced a similar symptoms were claiming a software conflict. So I manually added: the access point connections, the text messaging number, and the voice mail number as per these 3 koodo community posts:
When that didn’t change the phones behavior, I deleted the old rogers info from the locations listed in the above links. In theory, the phone shouldn’t even be looking for rogers anymore. If I take unit out of airplane mode to even attempt to choose a network ... the restart loop begins again :(  One last test that I've been able to complete today was to take a sim from a deactivated samsung E1100 to see if the same issue would persist - only error was unregistered sim (no reboot issue). Will try a sim from a friends phone tomorrow to see what happens.
Is there anything that I'm missing that will solve this issue aside from buying a new phone?

2 replies

Userlevel 7
Badge +4
Have you tried to remove the SIM and do a factory reset of the device, then now that it's like a fresh phone straight out the box insert the SIM Card and go through the set up process of the phone? If not try that perhaps
ty for your response Paul. I had chosen the reset option from the menu's within the phone yesterday, and found the instructions for the master reset this afternoon via *2767*35855#. Unfortunately, there has been no change in behavior when the koodo sim is inserted.