Koodo Community

No service (international carrier not picking up) in South Korea

  • 16 September 2018
  • 9 replies

After landing in South Korea, no local carrier could be picked up. I tried both automatic and manually selecting but it continuously says “No Service”.

Is there any reason why this might be happening?

I dont have an international romaning plan, but I thought the carrier should still pick up?

I am using an iPhone X.

Any help would be appreciated!

This topic has been closed for comments

9 replies

Userlevel 7
Badge +4
I assumed you are a postpaid (monthly) customer.
If you would like to roam with Koodo you could follow this instruction https://www.koodomobile.com/help/easy-roam
Badge +4
If you dont have a International roaming plan(EasyRoam $12 per 24hrs) on your account make sure you have the correct add-ons for your phone to work using pay per use rates. You might find EasyRoam a better option. Restart your phone if needed.


International roaming only works for postpaid accounts. Prepaid only works in Canada and the USA.

Don't want to use Easy Roam?

If you don't use Easy Roam while travelling, your talk, text and data usage will be charged separately from your regular monthly plan at our pay-per-use rates.
To access pay-per-use rates outside the U.S., you'll need to add the International Voice Roaming and International Data Roaming add-ons to your account if you want your phone to work abroad. If you're using Easy Roam while travelling abroad, you don't need to do this.
Thanks, so I realized I didn’t have the “International Voice Roaming” add on, and I logged into my account and added it.

It’s been a half hour and I’ve tried restarting my phone and it still won’t pick up a local network carrier here in Korea?

See attached photos indicating my settings and “no service” showing:

Please turn off automatic network selection
Ater your do, your phone will scan the area looking for roaming partners. Choose an available network from the list.

Keep in mind Koodo can't guarantee network availability while you're traveling so it's possible the area you're in just doesn't have a roaming partners available.

Edit: also be sure you don't have a balance owing that's past due.
Userlevel 7
Badge +4
Have you tried a network settings reset in your reset submenu?
Userlevel 7
Badge +4
@KoodoZ : I would add the "easyroam" add on, that would add both the international data and voice roaming. There might be issues with a single add-on. When you log in to selfserve, click on easyroam detail and add it in the add-on section

After that, try to reset network settings (Settings >> General >> Reset Network Settings) and restart the phone.
Hopefully it helps.

UPDATED/EDITED: This is what I had after adding easyroam into my number (I crossed out 2 add-on as they were there before adding easyroam)

Userlevel 1
Do you have to use your number over there for any particular reasons? If not, you can rent a pocket wifi at the airport for about $20 CAD/6 days, high speed unlimited data and up to 6 users. Then use Skype to call and sms back to Canada.
Thanks for the suggestion! I’m actually already doing that now (the pocket wifi) so it’s been working out great.

I’m just concerned for travelling in the future on the Koodo network. I switched to Koodo recently, earlier this year but haven’t been outside of Canada until now. Every other carrier I used has automatically been able to pick up a local carrier upon landing in the international destination. I just wanted this to be the case with Koodo as well, for emergency purposes. Ideally I would never have to use it, but in the case of emergency I would like the ability to call home immediately roaming on another network, since I wouldn’t be able to get a new sim or a pocket wifi on the spot (if it were a true emergency)

If Koodo doesn’t automatically pick up international carriers when travelling, it might be an issue I have to consider in the future.
Userlevel 7
Badge +4
If Koodo doesn’t automatically pick up international carriers when travelling, it might be an issue I have to consider in the future.

@KoodoZ : the roaming is an extra feature that need people to enroll https://www.koodomobile.com/help/easy-roam If you don't have easyroam (or payperuse) and/or roaming add-on, then you cannot roam. It was designed that way.

Some people actually prefer it as it prevents accidental expensive charge.

Normally people did it before traveling. A text "ROAM" to 7626 would do. In your case, I would suggest you try several suggestion above. You could also contact Koodo through facebook (https://www.facebook.com/Koodo) or twitter while you are oversea.