Koodo Community

No Network Service

  • 13 December 2021
  • 7 replies
  • 96 views

Yesterday my mobile connection was not working very well and the data service was not working. I tried turning phone on and off, and now I have no service at all for the past day.

I have had my current phone(LG G6) and SIM card for probably 3 years, and haven’t recently made any changes to my plan.

What I’ve tried so far:

  • I checked and there doesn’t appear to be an outage in my area(Burlington ON).
  • Bill is paid and nothings seems wrong from self serve website.
  • I’ve removed and reinserted the SIM card.
  • I’ve reset the network settings.
  • Powered on/off the phone.
  • Try to search networks, but it returns immediately saying “Error while searching for networks”.
  • Also using a 3rd party app, I checked the SIM card state which seems to be “NETWORK LOCKED”.

Does anyone have any suggestions to resolve this issue?


This topic has been closed for comments

7 replies

Badge +4

Are you able to test the SIM card in a different phone to see if the problem follows the SIM?

Are you able to log into your self serve account?

Unfortunately, I don’t have another phone to test with.

And I am able to log into my self serve account.

Userlevel 7
Badge +4

Does the SIM card on self-serve match the one that’s in your phone (I’m thinking of SIM swap attack)?

Huh, how would I check the SIM card on self-serve? Am I looking for the IMEI to match?

Badge +4

I’ve flagged a rep for you. The ‘network locked’ message seems suspicious and as Robert mentioned, might be a SIM-swap attack. The rep will have the tools to better diagnose this problem. 

Userlevel 7
Badge +4

Hello @Parcels! You can check to see if your SIM card’s serial number is registered on your line in Self Serve by clicking on Self Serve - Mobile services - Change your SIM card.

Your Koodo account is not linked to Koodo Community so unfortunately we weren’t able to check on this. For more information, please log in with Self Serve here or send us a message on Facebook/Twitter. 

Ok Thanks, I will try to send a message on Facebook.

Looking at the self serve, it doesn’t show the full number, but it seems the first and last parts of the number do match.