Koodo Community

Community

Solved

no activation yet !!!!!!!!


I bought an IPHONE 4s with two year plan , the guy told that they will send an e-mail for activation in 24 hours, now its 30th hour but there is not an e-mail yet , what should I do, I am new in toronto and I dont have any idea

8 replies

Userlevel 4
Email for activating a phone? They should have done that in store. Prepaid or monthly (postpaid)
not activating for a phone , activating to sim card
Userlevel 7
gorkem picakci wrote:

not activating for a phone , activating to sim card

If you got this with a Tab then it should be instant activation. Where did you buy your phone? Do you have paper work? Did the rep test everything out to make sure it's working? (obviously not) I would try removing the SIM card for about a minute and try again. Make sure Airplane mode isn't on and you have 3G enabled.
Userlevel 4
gorkem picakci wrote:

not activating for a phone , activating to sim card

"I bought an IPHONE 4s with two year plan , the guy told that they will send an e-mail for activation in 24 hours" You mentioned phone in the description.
Userlevel 7
Badge +4
gorkem picakci wrote:

not activating for a phone , activating to sim card

Almost sounds like you might have been the victim of fraud... please answer Jonathan's questions, Gorkem, where did you buy the phone (what store) and what plan did you pick?
gorkem picakci wrote:

not activating for a phone , activating to sim card

from eaton centre , with a plan which I have to pay 47 $ for a month , and I pay nothing for iphone
Userlevel 7
gorkem picakci wrote:

not activating for a phone , activating to sim card

It's not fake if you got it from the koodo kiosk at eaton centre. Also gorkem, you can activate your sim online using self serve. Also You'll most likely have to wait until the system maintenance is done
Userlevel 7
You should have been able to place a call, text, and use data before even leaving the kiosk. This guy didn't do his job properly.

If he meant the registration e-mail for Self Serve then that's a bit more understandable and a different issue altogether, but postpaid phone service is nearly instant.

Have you ensured 3G is on under the cellular settings? Have you tried toggling Airplane mode? Do those things for me and update us, please. 🙂

Reply