Koodo Community
Question

issues with mobile data

  • 15 November 2022
  • 11 replies
  • 82 views

  • Advocate
  • 19 replies

I have been with Koodo since 2017 and recently noticed especially start of tgis year tbat when I connect to mobile data there is latency and signal drops. Settings are automatic and exact parameters similar to when you manually set network up.

 

This latency and signal drop is more evident when I am around Kanata.  Are there ongoing issues with koodo network?


11 replies

Userlevel 7
Badge +4

Is there anyone else you know with Koodo/Telus in the same area experiencing similar issues? Are you able to swap sim card with another phone to see if the problem follows? 

No unfortunately I do not know of anyone else with Koodo at the area.

 

I recently changed phones and it was happening to both phones so I doubt it is phone/phone brand related

It was a goodle phone and a Samsung phone

Google

Userlevel 7
Badge +4

It was a goodle phone and a Samsung phone

Did it happen to everywhere you went or it only happened to certain places? 

Also, are you a prepaid or postpaid customer?

Post

Userlevel 7
Badge +4

Post

A longer sentence of answer would be more useful. I guess you were the one who came here to seek help.

Userlevel 7
Badge +4

Have you tried resetting your phone’s network settings?

For most Samsung devices, go to Settings > General management - tap Reset, then tap Reset network settings and follow the on-screen prompts. 

For Google phones, go to Settings, tap System > Advanced > Reset options > Reset Wi-Fi, mobile & Bluetooth and follow the on-screen prompts.

Resetting your phone’s network settings restores cellular, Wi-Fi and Bluetooth to their factory default settings and sometimes resolves network connectivity problems. This procedure does not erase any user data. Though, you may have to re-enter Wi-Fi passwords, re-pair Bluetooth devices and reconfigure VPN settings (if applicable).

Keep us posted.

To Clarify I recently changed to a new phone/samsung and from using oneplus, then google, for the past 2 years I have noticed latench and signal drop and often whenever I go to or around Kanata.   I have called about it before that is why I know the parameters and of setting up network manually as the tech walked me through those things and yez includes resetting networks and so on..

 

I have bewn residing at Alta Vista-Kilborn for 8 years now and been with Koodo(post-paid) since 2017.  I was jist curious to have read a post revarding Koodo latency and weak signal/drop since adding 5G..

 

From the time that it did start was when I notice the change in reliability of the signal especially data.  It just so happena that I only posted about it recently but has been a long-time and on-going issue.

 

THhe manager at a koodo kiosk I know told me to get a new sim and see how it goes.  I'm sure people whom have similar experience and concerns will be interested to know.  I will update as soon as I have the time to get one.

The latency and signal drops happen doesnt matter where I am but notice it at different times of the day but really is bad to when i am at Kanata area where its as if I have no signal or network there.   OBviously I'm not always at Kanata but pointing it out I noticed it to be more prevalent there.  Where I live and what phones I use arent the issue as the only change that happened is when 5G started.. and it happens  o matter what phone i had nor if I set the network manually.

Userlevel 7
Badge +4

THhe manager at a koodo kiosk I know told me to get a new sim and see how it goes.  I'm sure people whom have similar experience and concerns will be interested to know.  I will update as soon as I have the time to get one.

Thank you for the clarification. It could very well be the SIM card as the problem seems to follow no matter which phone you insert your current SIM card into. If you’re using the same SIM card since 2017, it’s possible that it could be showing signs of aging. SIM cards have a pretty good track record for longevity, but they don’t last forever. Let us know if the new SIM card resolves the problem.

Reply