Koodo Community

Community

I CAN'T USE MY PHONE, NOT REGISTERED ON A NETWORK


Userlevel 1
I had my Samsung Galaxy Ace phone from Koodo less than a month ago. This morning when I tried to call my friend it says not registered on a network. I tried to pull the battery and sim out but it did nothing. I asked my friend to call my number but it goes directly to my Voicemail. I just couldn't use my phone. What can I do?

21 replies

Userlevel 6
Did you try: -manually searching for & selecting the Mobile Network "Telus" or "Koodo"? -resetting the APN to Default?
John Burke wrote:

Did you try: -manually searching for & selecting the Mobile Network "Telus" or "Koodo"? -resett...

Bell Samsung 4 says not registered when I call my friends
John Burke wrote:

Did you try: -manually searching for & selecting the Mobile Network "Telus" or "Koodo"? -resett...

Also the koodoo cell I had I paid of my bill plus tab and also sold to a friend why then is this cell still activated when they have their own card in it
John Burke wrote:

Did you try: -manually searching for & selecting the Mobile Network "Telus" or "Koodo"? -resett...

9023023408
John Burke wrote:

Did you try: -manually searching for & selecting the Mobile Network "Telus" or "Koodo"? -resett...

Bell 9926314249
Userlevel 7
Badge +4
John Burke wrote:

Did you try: -manually searching for & selecting the Mobile Network "Telus" or "Koodo"? -resett...

Hi, Janie.
Is your Bell phone unlocked?
Also you sold your Koodo phone to your friend. Is your friend with Koodo or different service provider?
If you can post new question, you will get answer/help quicker.
Userlevel 7
Badge +4
Make sure the phone didn't accidentally get set to 2g or GSM only in the network settings. Also make sure that you didn't accidentally turn on airplane mode, press and hold the power button like you were going to turn the phone off and when the options come up make sure where it says airplane mode that it doesn't say on. If it does say on tap it to turn it off.
Paul "Kid Android" Deschamps wrote:

Make sure the phone didn't accidentally get set to 2g or GSM only in the network settings. Also m...

Thanks for your hints as it was the GSM setting that was the prob. Somehow it got switched from LTE!
Paul "Kid Android" Deschamps wrote:

Make sure the phone didn't accidentally get set to 2g or GSM only in the network settings. Also m...

Hi! I have the same problem. were can I find the GSM mode and which one it should be? Thanks!
Userlevel 7
Badge +4
Paul "Kid Android" Deschamps wrote:

Make sure the phone didn't accidentally get set to 2g or GSM only in the network settings. Also m...

What phone do you have?
Did you restart your phone? Postpaid or prepaid? Can you start your own question using this link?
We need more info to help you.
https://community.koodomobile.com/koo...
Paul "Kid Android" Deschamps wrote:

Make sure the phone didn't accidentally get set to 2g or GSM only in the network settings. Also m...

Hey! I have sumsung galaxy 5 and I am in monthly paid. I desperately need to be able to use my device to recipe messages from Canada in Israel. What should I do?
Userlevel 7
Badge +4
Paul "Kid Android" Deschamps wrote:

Make sure the phone didn't accidentally get set to 2g or GSM only in the network settings. Also m...

So, you are in Israel? Can you check your self serve to see if you have “International voice roaming” ? Check this link about Roaming. https://www.koodomobile.com/easyroam?INTCMP=KMNew_NavMenu_Shop_TravelAndRoaming
Paul "Kid Android" Deschamps wrote:

Make sure the phone didn't accidentally get set to 2g or GSM only in the network settings. Also m...

Did it! Thanks so much
Userlevel 2
Hey Lotus, let us know if you were able to get this resolved. Thanks.

________________________
If you see a good answer, give it a star.

Mine does the same thing! It display s Koodo on my screen but I can't use it as I'm not registered on the network ... Of course the koodo system is upgrading and customer service is closed 😞
Userlevel 7
Badge +4
Chelsea Hamilton - Parkin wrote:

Mine does the same thing! It display s Koodo on my screen but I can't use it as I'm not registere...

It could be your sim card.  Did you try to take a sim out and put it back in?
I had a same trouble a few days ago. I took sim card out and in more than few times and I got connected again.
Chelsea Hamilton - Parkin wrote:

Mine does the same thing! It display s Koodo on my screen but I can't use it as I'm not registere...

It's back working again! Thank you 🙂
Mine is only working sporadically, mostly not working.  When I say "select network provider automatically" I immediately get a message "registered on network".  But then when I try to call, "not registered on network."  Maybe I shouldn't have chosen Schrodinger's network.
I would like to register myphone
Userlevel 7
Badge +4
Donald Brooks wrote:

I would like to register myphone

Are you a Koodo customer already? If not, you will need to stop by a Koodo store to obtain a SIM card & instructions to set it up.

I would like to register my phone

Reply