Koodo Community

Cannot connect call through to my spouse who is also koodo customer

  • 18 January 2021
  • 1 reply
  • 31 views

Lately anytime my spouse tries to phone me or vice versa, it will ring and then just go to silence before hanging up after ~10 seconds and then my iPhone says call failed.  We are both koodo customers and haven’t had any problems until recently.  My partner has an alcatel go flip 3.

It started on my old iPhone but then I got a new one and it does the same thing with the new one.  I also went down to the kiosk and got a new sim and he restarted the network to no avail.  I tried restarting the phone, and no luck.

I’ve also had it drop calls lately twice while I was at home and really shouldn’t of had a dropped call. anyone have any other ideas?  In a pandemic I don’t want to be leaving the house to hit up a crowded mall everyday but it’s really important that I be able to actually reach people.

 

Thanks!

 


1 reply

Userlevel 7
Badge +4

Thats weird.  Usually it is the sim or the phone, but it seems like you tried a new sim and phone.

Could it be a tower issue in your area?  Is there anyone else using Koodo/telus with the same issues?  If you go to different areas of your city does the situation change?  How many bars are you getting on your phone?

Reply