Koodo Community
Solved

Can't receive SMS when overseas


I’m currently overseas and need to receive OTP from my bank urgently. However, I found my phone is not connected to any mobile carrier right now so I’m unable to receive messages. 

I read below article and it claimed anyone should be able to receive message when abroad but it’s not the case with me. Please help 

 

https://community.koodomobile.com/plans-add-ons-66722/receiving-sms-while-abroad-7798727

icon

Best answer by Mihaela Koodo 14 October 2020, 18:05

Hey CaraW! Can you, please, try to turn your phone OFF and back ON again? It should be working now, but make sure to turn your mobile data OFF, to avoid roaming charges. I can see there’s no easy roam feature added for now, but if you need to, you can have it added on koodomobile.com/selfserve. 

View original

14 replies

Userlevel 7
Badge +4

 

  1. Is Roaming enabled in your your cell settings?
  2. Is your network setting set manually to ‘koodo’?
  3. Is your ‘automatic network selection’ enabled?

 

  1. no I don’t have easy roam enabled because I only need to receive SMS
  1. It’s not, should I? 
  2. it’s automatic now 
  3. yes 
Userlevel 7
Badge +4

You do not need easy roam to send/receive SMSs abroad

I would try to enable ‘Roaming’ to test sending/receiving of SMSs (may result in a roaming fee?)

If automatic network selection is enabled, can you see a local mobile provider selected?

I enabled roaming and still has “no service”

 

When I opened the automatic network selection, none of the local mobile provider are selected 

I also tried to turn off automatic and picked the local mobile providers manually 1 by 1 and none of them can be connected 

Userlevel 7
Badge +4

Can you restart your phone and see if a local mobile network is selected?

I tried  multiple times and didn’t work

Userlevel 7
Badge +4

If the phone restart doesn’t work, I would try to reset the network settings and reboot again.

Also, not sure where you are, but some countries’ cell systems may not be compatible with your phone.

Check https://willmyphonework.net/ to see which mobile network providers are most likely to work with your phone

 

Userlevel 7
Badge +4

I also tried to turn off automatic and picked the local mobile providers manually 1 by 1 and none of them can be connected 

Are you allowing the time to connect to the local network? It's takes a few minutes to scan and connect. 

When you try to connect does it display an error? 

 

What phone are you using? 

What country are you in? 

Is your koodo account in good standing and all bills paid up? 

yes of course I gave it time, it was searching and then it stopped and showed No Service.

There was no error messages at all, simply searching and then stopped and show no service

 

I’m using iPhone, I have contacted apple support and made sure it’s hardware failure. 

I’m in Taiwan right now and my account is in good standing and yes I”m still paying my bill 

Userlevel 7
Badge +4

You mentioned "right now".  Were you able connect previously?

Are you able to try a local Taiwanese sim in the phone? Or your koodo sim in another phone? 

 

Just to cover our basis, can you also enable easy roam? This is likely not the issue but it won't charge you anything as long as you don't send a text, talk, or use data. 

no I’m not able to connect anytime after I landed Taiwan with my KOODO sim

however, I can connect with my local sim 

I have enabled easy roam while troubleshooting and it didn’t work 

Userlevel 5

Hey CaraW! Can you, please, try to turn your phone OFF and back ON again? It should be working now, but make sure to turn your mobile data OFF, to avoid roaming charges. I can see there’s no easy roam feature added for now, but if you need to, you can have it added on koodomobile.com/selfserve. 

Thanks Mihaela, it works now!

 

Thank you everyone for trying to help!

Reply