Wrong time zone after time change (Day light saving time)

  • 3
  • Question
  • Updated 4 years ago
  • Answered
So the daylight saving time ends as of Sunday. The clock should be go back in one hour. However, my phone now shows wrong time zone and time is one hour ahead of actual time. Problem with both iPhone 5C with Kood and iPhone 6 with Telus. However, iPhone 6 plus with Fido (my father's phone) is on right time. That leads me believe this is carrier issue rather than my phone's issue.
Photo of Yang Chao

Yang Chao

  • 110 Points 100 badge 2x thumb

Posted 4 years ago

  • 3
Photo of Trace

Trace

  • 414 Points 250 badge 2x thumb
Turn the phone off and back on again. My SGSIII is fine.
Photo of Yang Chao

Yang Chao

  • 110 Points 100 badge 2x thumb
I have tried turn off and back on again. No luck. I tried everything beside flashing the firmware again.
Photo of David

David, Mobile Master

  • 89,270 Points 50k badge 2x thumb
Also make sure Settings > General > Date & Time are set to 'Set Automatically'. If that does not work, a short term fix is to choose an appropriate time zone to provide the correct time.
Photo of Yang Chao

Yang Chao

  • 110 Points 100 badge 2x thumb
Oh, Hello. Thanks for reply. The Data and Time are set to Set Automatically. It is setted to GMT+4.
Photo of David

David, Mobile Master

  • 89,270 Points 50k badge 2x thumb
GMT +4 puts you somewhere in the Middle East or Russia, you might try setting it manually to a city in your local time zone.
Photo of mmccas22

mmccas22

  • 70 Points
Same thing happened to my iphone 6. It was correct when I woke up this morining but then changed itself to the same GMT+4. I can't get it to stay in the right time zone without turning off automatic set. I turned the phone off two seperate times to no avail. This is so frustrating.
Photo of David

David, Mobile Master

  • 89,034 Points 50k badge 2x thumb
You WON'T get it to change from GMT+4, as that information is not managed by your phone, but by the cellular network. I suggest contacting Koodo directly with your location so they can address the particular cell site you are connecting to. Only once it is addressed there will your phone show your local time zone.

My guess is the ICANN tz database setting is not correctly set for the cell site(s) you are connecting to.

In the meantime, the only fix available to you is to manually set your phone to an appropriate time zone.
Photo of mmccas22

mmccas22

  • 70 Points
Ok thank you, very good to know.
Photo of jtclark

jtclark

  • 62 Points
Photo of Shyam Kumaria

Shyam Kumaria

  • 60 Points
Try switching off "set automatically ". Then turn it back on again.
Photo of Khaleila

Khaleila

  • 4,102 Points 4k badge 2x thumb
Hey Yang Chao & mmccas22,

Try switching off "Set automatically" then do a hard reset (holding down the sleep/wake button and the home button at the same time) until you see the Apple logo appear. The device will restart on its own, simply go back into: Settings/General/Date and time then switch "Set automatically" to "ON". Hope this helps.

________________________
If you see a good answer, give it a star.

This conversation is no longer open for comments or replies.