Windows 8 Dual Sim Phone - keeps trying to connect to Rogers?!? upon returning to Canada.

  • 1
  • Question
  • Updated 3 years ago
  • Answered

so I have an issue with my Koodo sim card on my new BLU - Windows 8 dual sim phone.

Here is the problem: Every time i cross back into Canada with this phone the Koodo sim wont locate the koodo network and keeps trying/ wanting to connect to either Rogers or EXT?

I have re-imputed the data into the APN settings(as suggested by 2 local stores) but I am still unable to connect to or even locate the network. I have 4g coverage in my area but even at the koodo stores struggle to get it to connect.

Short of replacing the Sim again is there any way to do a 'force connect' to network type action.
Photo of Samuel B

Samuel B

  • 80 Points 75 badge 2x thumb

Posted 3 years ago

  • 1
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,644 Points 100k badge 2x thumb
Where are you returning from
Where do you live?
Apn has nothing to do with what cell network the phone will try to connect to.

Have you tried the Sim in the other slot?

Which Blu Win do your have?

Ext is fine Btw depending on where you are. Even if your phone says Roaming.

Is 2g or GSM only selected? Make sure it's not.
Photo of Jonathan I

Jonathan I, Mobile Master

  • 114,344 Points 100k badge 2x thumb
Have you tried using your Koodo SIM in the other slot? One of the slots might be 2G only, which is why it won't be picked up by Koodo.
Photo of Samuel B

Samuel B

  • 80 Points 75 badge 2x thumb
Hi Guys thanks for the quick replies;

I live Abbotsford BC, so just outside of metro Vancouver. As such I cross into the USA on frequent basis.

I have tried the Sim in both slots, neither seems to affect its functionality.

Both sim slots are 4g(both stores previously suggested rotating them, it worked last time but not this time). When EXT/ Rogers displays it is always in 2g and I can never connect to either network.

I have a BLU WIN HD W510u,

About 2 minutes after the original post went up, my Koodo sim finally connected. I have made sure data was active, as i read on a few other posts that this could cause connectivity issues. I usually keep it set to not roam on data for obvious reasons, but had reset it to roam quite some time before it connected.

Any suggestions to help avoid this next time round would be much appreciated.

Photo of Ivan

Ivan, Mobile Master

  • 95,438 Points 50k badge 2x thumb
While both slots can accept a card that connects to a 3G/LTE network, only one active 3G/LTE connection can be active at a time. If you have 2 SIM cards inserted, one will always default to 2G only,

To prevent this, I suggest that you have your connection type set to 3G (or 4G) only.
Photo of Beverley


  • 1,008 Points 1k badge 2x thumb
In the phone settings you have to identify which sim you wish to use for data and then the other sim becomes 2g only. Rogers is the only carrier in Canada that uses 2 g.
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,644 Points 100k badge 2x thumb
Beverly is right! I have that phone and forgot all about that.!

It's under settings... Sim I think
Photo of Big Abe

Big Abe

  • 60 Points
I'm having a similar problem with a similar phone.

Phone: Microsoft Lumia 640 XL (Dual-LTE Sim)
Main SIM - Rogers LTE
Personal SIM - KooDo

IF I power on the phone with JUST the koodo sim in it, it connects no problem. I can then power down the phone, insert the rogers sim and power it up and I have both connections. The moment I lose signal on Koodo, it's gone forever until I repeat the above process.

I've also tried this on WP8.1 Update 2, as well as Windows 10 preview. All have the same story. I don't believe this phone fails to 2G on the non-data SIM, as it's intended to be dual-lte. With 2 Rogers SIMS I have no issues. I also have no issue with Rogers and Wind SIMs (but WIND is VERY slow to connect).

However, Rogers + KooDo = no happy. Sad panda.