Wifi won't connect on moto g

  • 18
  • Question
  • Updated 2 years ago
  • Answered
  • (Edited)
I just got a moto g, and the wifi wont connect. I know im on the right network and the passwoed is right, but it keeps saying "authentication problem" any ideas?
Photo of Josh Foisey

Josh Foisey

  • 260 Points 250 badge 2x thumb

Posted 4 years ago

  • 18
Photo of Dennis

Dennis, Mobile Master

  • 187,758 Points 100k badge 2x thumb
Have you tried to confirm your password is correct by trying to connect to that wifi with that password with another device (manually do it to confirm it's not truly a password issue)
Photo of Josh Foisey

Josh Foisey

  • 260 Points 250 badge 2x thumb
My laptop is on it right now.
Photo of Devendra Singh

Devendra Singh

  • 60 Points
cant open to wifi like when i tap to on option it automatically gets off !! what to do ?
and same with option for hotspot .... rest options are working properly
Photo of Chad Burr

Chad Burr, Mobile Master

  • 202,108 Points 100k badge 2x thumb
Did you try the suggestions above?
Photo of pavan kumar

pavan kumar

  • 60 Points
Hi, It happens too me on moto g 1 gen, recently I found a temporary solution for this issue ....1.) forgot your WiFi network, 2.)clear catche under settings-storage menu. 3.)Reboot your device immediately4.) Turn on your WiFi and give password ,click connect and wait for some time it will connect, if not leave it alone for 1/2 to 1 hour and again click on connect .. Sure you will get connected to your WiFi...
Photo of Deepak Kumar

Deepak Kumar

  • 70 Points
bakwas
Photo of Matthew Sider

Matthew Sider

  • 2,432 Points 2k badge 2x thumb
Wen Wi-Fi dose not work peroply. There couple things comes to mind. bad software you may need do a reset. of the phone may help you. or droped
It all Android is Unixes. software by goolge
If restet dose not tray push force to stop android system claer all your casha, by buttion down or
If LG g3 You may have potion to clear this
Buy puching botten on rigth had side
I hope this helps you pleses have stress free Day
Thank you
Photo of Josh Foisey

Josh Foisey

  • 260 Points 250 badge 2x thumb
Didn't work
Photo of Dennis

Dennis, Mobile Master

  • 184,868 Points 100k badge 2x thumb
Hmm... mine connects to wifi.

Restart it
Photo of Carolyn Walker

Carolyn Walker

  • 60 Points
Did you reset your device? If so...make sure you are using the Wi-Fi security Key and NOT your password. You will find the key on the bottom of your modem/router.
Photo of Abhishek Dhiman

Abhishek Dhiman

  • 60 Points
Hey...there is wifi bug in lollipop 5.0 update....do first restart ur moto in fastboot boot...go to recovery...and then clear cache partion...no third party app can help u clear this...so clearing this will help ur wifi problem and some other issues that are on moto G2 , G1
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,968 Points 100k badge 2x thumb
Open the wifi on your Moto G and long press your home wifi. Then tap forget.

After your phone rescans, choose the home network again. Enter the information and reconnect.

Also try power cycling the router, (unplug the electrical connection from the router then plug it back in) if this works consider placing your router on a timer that shuts it down for a minute or two each day (mine does so at 3am)
(Edited)
Photo of Tom Elm

Tom Elm

  • 62 Points
hey, this worked great....thanks
Photo of Josh Foisey

Josh Foisey

  • 260 Points 250 badge 2x thumb
I did this already. I just don't get why it won't connect..
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,968 Points 100k badge 2x thumb
Does your router support push button connections?

If so try connecting that way

Look for the symbol on your router on in your routers setup menu

It looks like two arrows pointing ateeach other's tail. Lower left side of the wifi screen.
Photo of Pam Julien

Pam Julien

  • 62 Points
I bought my moto g last Saturday and I am experiencing the same problem 'authentication problem'. My other devices connect to wifi. Please help!?
Photo of Moto G

Moto G

  • 6,066 Points 5k badge 2x thumb
I have same problem when at Tim Hortons. I get WiFi reading on moto g. I check connection, it says connected, signal strength excellent. But all app updates fail, giving fail numbers. But not at Mc Donalds where a "connection" pop up comes up, for me to click "connect".
If there is not box for me to "connect" no WiFi.
Photo of Jonathan I

Jonathan I, Mobile Master

  • 114,244 Points 100k badge 2x thumb
Oh, that's different. When you're using a public WiFi network like McDonald's, Tim Hortons, Pizza Pizza, etc. typically you need to open your browser and accept the company's terms and conditions before the WiFi will push through your device.
Photo of Moto G

Moto G

  • 6,066 Points 5k badge 2x thumb
Oh wow! So then I should use the Tim Horton's app for this? Whereas Mc Donalds just sends my phone "the pop up"?
Photo of Jonathan I

Jonathan I, Mobile Master

  • 114,244 Points 100k badge 2x thumb
No, you just need to go into your browser. The Tim Hortons app would just allow you to browse their menu and prices, nutrition info, etc.
Photo of Moto G

Moto G

  • 6,066 Points 5k badge 2x thumb
thanks Johnathon
Photo of Dev Anand

Dev Anand

  • 80 Points 75 badge 2x thumb
Hi there is some WIFI problem in Moto G .. i cannot connect it ...

could you pl help me how to resolve this...
Photo of matthiasdvs .

matthiasdvs .

  • 90 Points 75 badge 2x thumb
i have the same problem!! nothing works, i even did a live chat but i didnt help ...
Photo of Frank Shumaker

Frank Shumaker

  • 120 Points 100 badge 2x thumb
I have same problem too! All the time it just loses connection. That "Authentication problem" message makes me puke. I can't stand it. Updated to newest kernel, Android 4.4.2
Photo of Lizz Paradise

Lizz Paradise

  • 84 Points 75 badge 2x thumb
Mine bounces between authentication problem and temporarily avoiding poor connection even when I'm standing next to the router
Photo of jen

jen

  • 72 Points
I have same problem, connects automatically everywhere except for 1 place. Don't understand why it won't just connect, it did up until about a month ago now just says ' saved, secured' but not connected. Data charges really add up. Not too happy with koodo
Photo of rikkster

rikkster, Mobile Master

  • 66,890 Points 50k badge 2x thumb
Usually when that happens, the password to the access point or wireless router may have changed or you may have entered the password incorrectly from your Moto G. I can't see any fault with your phone as you're able to connect to other access points without issue.
Photo of jen

jen

  • 72 Points
The password is correct, everyone in the office can access the wifi using this password.  This is exactly why I don't understand what is wrong.
Photo of rikkster

rikkster, Mobile Master

  • 67,104 Points 50k badge 2x thumb
One tried and true method is to make your wireless device a preferred device on your wireless router using MAC address filtering. This works for any device that connects to Wi-Fi and solves many connectivity issues. Basically, MAC address filtering allows you to specify which devices have access to the wireless router and the internet.

Since your phones' MAC address will be stored in the wireless routers memory, your wireless device will connect each and every time you're in range of the wireless router. To set up MAC address filtering, first open up a browser and look at the underside of your wireless router for the default IP address. The numbers should look something like this; 192.168.x.x. Enter those numbers into your browser.

You should now be at the login screen of your router. Login if you've created a username and password, otherwise you may have to lookup the default username and password settings for your particular router. At this point you will need to temporarily disable your wireless routers security, so that it shows NONE. This will allow both the wireless router and your wireless device to 'see' each other.

On the Moto G go to: Settings > About phone - tap Status. Scroll down to Wi-Fi MAC address and write down the series of alphanumeric characters;
(e.g., 30:BC:B6:FB:4C:32). Once you have the Wi-Fi MAC address for the Moto G, re-enable your router's wireless security (e.g. WPA2, etc.). Navigate to your MAC address filter page, (usually found under Wireless/MAC filter).

At this point, your Moto G should be able to connect to the router. Manually type the MAC address into the box provided, (it may have a bunch of zeros that look like this: 00:00:00:00:00:00) Some routers may have a wireless client list where you can add devices that are already connected to the router. After you've added the Wi-Fi MAC address from the Moto G, click SAVE and then log off.

It looks like a lot to read, but in actuality it's only a few mouse clicks, a little bit of typing and you're done. I've been using this method for years and have never had any Wi-Fi connectivity issues. It's an extra step, but well worth it and you'll never have to worry about losing Wi-Fi again.
Photo of Melodie New

Melodie New

  • 70 Points
THIS HAS WORKED ON MY MOTO G. 18th Feb 2014
I have had this puzzle now ALL WEEK and the solution was so easy eventually but NOT at all obvious. I hope this will also help others with this same 'Authentication Problem' It really was starting to do my head in as I KNEW I was typing the correct Password that was written on the Router. Ho Ho Ho, how wrong was I. In desperation I tried typing in the Wireless Key number that was written on the Router instead of the Password. I couldn't believe it when it worked and I was able to do the Android KitKat update with my WiFi connection. Not bad for an ageing woman Silver Surfer aye. I did try Rikkster's solution but I got worried about altering my router setting so abandoned that. Good luck and I hope this helps.
Photo of rikkster

rikkster, Mobile Master

  • 67,104 Points 50k badge 2x thumb
This must be a Bell 2Wire router. The router itself has the wireless encryption key and SSID code printed on it, the password is not printed anywhere on the router and is generated by Bell upon setting up an account and starts with "b1xxxx##". Glad you were able to get the update though.
Photo of Melodie New

Melodie New

  • 70 Points
No, it's a Thompson 585 G8 with Router address, User, Password, Wireless name and Wireless Key all written on it from Plusnet. It was the Wireless Key that I typed in on my Moto G and not the Password. Spent ages trying to suss that one out with my ageing brain cells. Everything working first class and loving my Moto G.
Photo of Asweez Perla

Asweez Perla

  • 60 Points
Thanks worked for my moto e
Photo of Steve

Steve

  • 4,030 Points 4k badge 2x thumb
One of the big snafu’s with McDonalds or Tim Horton’s type of service is the Wifi will appear to connect but it won’t let your phone do anything (like download mail, etc.) until you open up a web browser and accept or agree the terms and disclaimer from their captive portal.

I find Wifi Manager on the Google Play store is invaluable. At least it tells you what it is doing and lets you select which Wifi network you want. Basically my android phone won't connect reliably with out it and with it I have no problems.
Photo of Moto G

Moto G

  • 6,066 Points 5k badge 2x thumb
What throws me off with the Moto G is the missing arrows, similar to those of the S2x.
It never occurred to me to get a WiFi Manager at Play Store. That was a really good TIP Steve.
Thanks!
Photo of Ramesh Ashok

Ramesh Ashok

  • 60 Points
select eap as : PEAP and phase 2 as : MSCHAPV2, then login again with credentials, it will work.
Photo of Raghavendra Joshi

Raghavendra Joshi

  • 90 Points 75 badge 2x thumb
@Ramesh: it shows failed to save the network :(
Photo of sarath

sarath

  • 82 Points 75 badge 2x thumb
Why wt happened?
Photo of Yogesh James

Yogesh James

  • 60 Points
Hey i had the same problem with WPA encription. I went into the wifi settings and selected advanced option. there you will see a DCHP setting, select it and change it from none to static. I did that and it solved my problem :D
Photo of Raghavendra Joshi

Raghavendra Joshi

  • 90 Points 75 badge 2x thumb
oh Thats great... I updated to kitkat... and that solved the problem too..
Photo of Frank Shumaker

Frank Shumaker

  • 120 Points 100 badge 2x thumb
@Yogesh, where are you seeing static DHCP setting?

My phone connects with WPA2, shows "Saved, Secured with WPA/WPA2", then when exit menu and come back, shows "Authentication problem".

This is horrible customer experience. No box either.

Anyone have any idea how to solve this issue?
Kernel: 3.4.0 Thu Jan 9, 2014
Android: 4.4.2

Regards.
Photo of Frank Shumaker

Frank Shumaker

  • 120 Points 100 badge 2x thumb
Wait, I got it working. What a pain.

Tap Settings, when Wifi. Tap on the three dots lower right corner of screen, the "menu". Tap "forget". When you enter the settings again, make sure you see the DHCP option, if you don't then you are in the wrong screen.

Somehow, I can't remember, the authentication problem was caused from entering the password in a type of shortcut screen or something like that. When entered from this short menu there are problems.
Have you tried clearing the cache partition on you device.. it might work to solve the wifi connectivity issue.

How do I clear Cache Partition on my device?

This will remove any temporary files that may be causing the problem, but will not delete your files or settings.

1. With the phone powered off, press the VOL DOWN KEY for 2-3 seconds then POWER key then release.
2. The device will display different BOOT OPTIONS
3. Use the VOL DOWN Key to SCROLL to Recovery and VOL UP Key to select
Tip: If the device reboots, you may have waited to long to make a selection, you will need to begin the process again.
4. The device will display the Motorola logo and then the Android in distress ( logo with Exclamation mark)
5. Press and hold the VOL UP key for 10-15 seconds. While still holding the VOL UP key tap and release the POWER key
Tip: You can try this step, holding the phone in landscape. If you are stuck on step 6, try a force reboot by pressing the Power key and Vol Down key, and start the process again.
6. The device will display additional menu options (Text will appear in BLUE)
7. Use the VOL DOWN Key to scroll to wipe cache partition and the POWER Key to select this option
8. The device will then perform the partition wipe
9. The device will reboot and start the normal power up sequence
Photo of Nentawe Gurumdimma

Nentawe Gurumdimma

  • 60 Points
I tried changing from DHCP to static, still was disconnecting after few seconds
Photo of Mac

Mac

  • 100 Points 100 badge 2x thumb
i got a moto g recently. while it connects to the home wifi as well as another wifi network but i cannot access the internet an other features such as gmail, youtube, etc on my home wifi but i access the same features through another wifi. my home wifi router is iball baton iB-WRT300N. other devices except moto g can acess net through iball. plzz help
Photo of rikkster

rikkster, Mobile Master

  • 66,890 Points 50k badge 2x thumb
Click on the link above, scroll to the middle of the page and you'll see the image as below. Click on the Downloads tab, then click on iB-WRT300N 1.0.5 and download the firmware upgrade for your router. (Click on either image to enlarge).



Photo of Mac

Mac

  • 100 Points 100 badge 2x thumb
thanx a lot. i had already tried it earlier. but during the upgrade my server page says "YOU PUT A WRONG A FILE". while the file is a BIN file and my current firmware version on the server page shows to be - 2.11.38.0(UED.C2)3.9.9.5
some other sources point out that this error maybe show while installing an older firmware version while a latest version already exists ! thanks in advance !
Photo of rikkster

rikkster, Mobile Master

  • 66,890 Points 50k badge 2x thumb
You're welcome. Clearly the router appears to be at fault because you mention that your moto g is able to pick up other Wi-Fi networks including your home network (iB-WRT300N) but you are unable to access the internet through it. I would suggest contacting the manufacturer of the router (iBall) to assist you further.
Photo of Pravi Appu

Pravi Appu

  • 80 Points 75 badge 2x thumb
I also have the same problem. My moto G works fine in other WIFI except at my work place. We are using D-Link 2750U. Can anybody help me out
Photo of Mac

Mac

  • 100 Points 100 badge 2x thumb
Yeah rikkster is right . the router was not configured well. Pravi appu , u can try contacting customer support of ur respective router. My problem is now solved
Photo of Naman Malhotra

Naman Malhotra

  • 60 Points
best solution:-
1. switch off your phone,
2. go to the boot menu,[press vol down(-) key and power simultaneously for few sec].
3.move down to recovery mode, then press vol up key to select.
4.your phone reboots with moto logo,
now if red triangle with android logo appears saying NO Command,

then hold vol up(+) key for 15 sec then push and release power button,

5.some more options appear, select clear partition cache, [note: it won't harm your data, your data remains as it is]

you are done, works for me
Photo of Pravi Appu

Pravi Appu

  • 80 Points 75 badge 2x thumb
Hey Mac, i checked my customer support of router and service provider(Airtel) they told everything is fine from their side and there is no problem at all. I even dropped a mail to MOTO care but no response.

Actually today i found out what was the problem all about. it's one of the application which was blocking to access the net. App name is MX Player.

I did reset of my mob and the everything was fine. the problem occured oagin only when i installed the App MX Player. Once i installed it again the internet stopped working, after uninstalling the App the problem was solved and the net is working fine now.
Photo of Pravi Appu

Pravi Appu

  • 80 Points 75 badge 2x thumb
Hey,

After 1 day, same problem stated, i didn't even installed that app but still the problem persist, dono what is the issue
Photo of Mac

Mac

  • 100 Points 100 badge 2x thumb
try clearing cache partiton(method written in some of the comments above).
try contacting flipkart for the issue ! get back soon. is your mobile data working fine. also check whether u are facing the same issue when connected to other wifi networks.